Manage Engine Desktop Central

Contributor III

Hi Admins,

Who here use Desktop Central Patch Management piece for their Manage Mac's to patch 3rd party apps? What are your experiences? Agent Installation process? Thanks in advance.


New Contributor

Really it is a good software. I am using in my company. I can install lots of software,patch via desktop central. I tried install desktop central agent to clients but it is not working. Still working on it.

New Contributor II

Hate to open up an old discussion from 2017, but are you able to share how you managed to push the client out to all jamf enrolled devices?

New Contributor II

@thuvarakan If you figured out a way, please let me know. The pkg file I downloaded from Desktop Central doesn't push out via jamf.

New Contributor III

@ray.henry , I also use Manage Engine's DC and always run into issues using the agent. The only way to fix this issue is by re-packaging the agent on your own, here is what I normally do to package it via Composer:

1- Download the agent from the DC site
2- Open Composer and drag your package from step 1 into it
3- Create a folder structure as you see in the screenshot above
4- Package it 5- Copy the package to to your DP and create your policy

If this is a machine with an existing agent on it, you might want to configure Files and Processes in your policy so that the Agent restarts after the upgrade


And this is how the package looks like in Composer


Hope this helps

New Contributor

I did end up putting the zip file into composer and create the package. However when I run the policy it doesn't install the package just puts it in the location that it was created from.

@user-gDwjmhTONC I believe that you should unpack it from the .zip and than drag it to composer.

Did you follow my instructions above? it still works for me. Make sure you check the permissions. you might need to Apply permissions to Users and All enclosed folders 


New Contributor

Hi @rnoureddine,


I followed your instructions, but agent is not installed successfully 😐. Although JAMF PRO will show successful status. Do you have any suggestions ?

New Contributor III

I remember this happening to me when the permissions on the subfolders did not match the root folder. That's the only thing that I can think of.

I have applied permission Owner:Root and Group:Admin to Library and all enclosed items.

New Contributor II

Hi, I am new to composer so please bear with me. Not sure what I am doing wrong. I have created the package from the source as described and applied the permissions. The files get copied to the target mac but the agent does not install. What am I missing - how do I get the agent to actually install?

Any help / guidance would be appreciated.



Hi @rnoureddine, first thanks for the lead on how to set this up.

But looking at your pictures, the Composer .pkg that you create would only place the folder in /users/shared/DCMacAgent... It would not install the agent on the machine.  If you have the missing piece, it would be greatly appreciated.

I will also dig it to see if I can find a solution

New Contributor III

I have the package set to "install" in the policy and also have the File and Processes configured to execute this command

/System/Library/CoreServices/RemoteManagement/ -restart -agent

New Contributor III

It's worth mentioning that over the last 2 updates we ran into some issues with the agent installed but the macs would not show up in DC until the next day. Also, we are using an on-prem DC and not the cloud version. 



Got it.  I also have the package set to install… But since the .pkg we built is only placing the folder DCMacAgent into /Users/Shared/ when you install it that what it installs… It doesn’t actually install the .pkg that came from DC, it only places the DCMacAgent folder in /Users/Shared/


Anyways, I added

sudo installer -pkg /Users/Shared/DCMacAgent/DesktopCentral_MacAgent.pkg -target /

To Files and Processes and it seems to have worked.  I only have tested on one Monterey and one Catalina. 

New Contributor III

Yes, the installer command from the readme needs to be run.

I didn't need to run the "kickstart" command, and scan results showed up instantly in SDP.  If you have trusted communication enabled, you'll have additional files in the .zip file to include.  It doesn't need to be go in /Users/Shared, it can be anywhere, but you'll want to set the owner/group in Composer.


Does anyone have any feedback on this software in regards to OSX patching?

Really just giving it a test run, but it seems like it can't install minor OSX Monterrey updates.

I also see no patching options for M1