MCX Disable Spaces - 10.7, 10.9 - Smarter Balance

Hiller
New Contributor II

For the Smarter Balance testing I am trying to disable spaces on numerous versions of the OS (trying it right now on 10.7.5 and 10.9).

What I need to change is to uncheck the second "Mission Control" option in preferences->Keyboard Shortcuts.

In jss I ...

  1. Select Managed Preferences
  2. New, Give it a name, "Enable Managed Preference Profile" is CHECKED
  3. Choose Custom and Manual Setting
  4. Select User-Level-at-every-login (tried the others too)
  5. Domain com.apple.dock (I also tried ~/Library/Preferences/com.apple.dock)
  6. Key mcx-expose-disabled
  7. Value Type "Boolean"
  8. Value True

I then scope it out for the computers I want, and while the setting ends up in the com.apple.dock file, it does not change the Mission Control option I am trying to turn off (nor does the Smarter Balance test run, stating "Spaces is enabled and must be turned off")

I have tried multiple reboots and logins to ensure the setting had a chance to take.

I have seen options to do this with configuration profiles (and not succeeded down that path,) BUT I would like to get this to work using Managed Preferences as it SHOULD work. I would like to succeed at managed preferences before I go try to learn something else.

Further, this command in terminal does not work for me either (both 10.9 or 10.7)

defaults write com.apple.dock mcx-expose-disabled -bool TRUE
killall Dock

Thanks!

11 REPLIES 11

jduvalmtb
Contributor

Wish I had a good response, other than I've been using
sudo -u $3 defaults write com.apple.dock mcx-expose-disabled -bool TRUE
on logout to disable Spaces for students, though it doesn't seem to do much to checkboxes like your program requires.

bajones
Contributor II

In my district, the special locked-down browser for SB testing required Spaces and Mission Control to be disabled. I forget how I discovered this, but the way it determined if these were enabled was by checking if the keyboard shortcuts to invoke these features were enabled. I ended up disabling them on one machine and capturing the com.apple.symbolichotkeys.plist and deploying these settings via configuration profile with a custom payload.

Here's the plist I used to create the custom payload in the config profile if you want to try this method:

https://www.dropbox.com/s/s62fyyi3zr2xn1a/com.apple.symbolichotkeys.plist?dl=0

cbrewer
Valued Contributor II

I have a login script that does this, but I've found it is somewhat unreliable. Writing to com.apple.symbolichotkeys.plist via defaults write does not seem to always take immediate effect.

#!/bin/bash

#Disable Mission Control Keyboard Shortcuts

su -l $3 -c 'defaults write com.apple.symbolichotkeys AppleSymbolicHotKeys -dict-add 81 "{enabled = 0; value = { parameters = (65535, 124, 262144); type = 'standard'; }; }"'
su -l $3 -c 'defaults write com.apple.symbolichotkeys AppleSymbolicHotKeys -dict-add 80 "{enabled = 0; value = { parameters = (65535, 123, 393216); type = 'standard'; }; }"'
su -l $3 -c 'defaults write com.apple.symbolichotkeys AppleSymbolicHotKeys -dict-add 79 "{enabled = 0; value = { parameters = (65535, 123, 262144); type = 'standard'; }; }"'
su -l $3 -c 'defaults write com.apple.symbolichotkeys AppleSymbolicHotKeys -dict-add 118 "{enabled = 0; value = { parameters = (65535, 18, 262144); type = 'standard'; }; }"'

colemj
New Contributor

Thanks bajones, worked great!

johnnasset
Contributor

We successfully used a config profile last year to disable spaces for SmarterBalanced testing. When upgrading to the new 7.0 version of the secure browser, I've found that either using a config profile or the above script works but not immediately. Not sure what it is but seems to take effect when I logout or restart. There must be some process that needs to be restarted for it to take effect.

RobertHammen
Valued Contributor II

cfprefsd in Mavericks and later caching preferences? Can you try a killall cfprefsd in your script (may want to scope to 10.9.x and 10.10.x to avoid an error) and see if takes effect right away?

johnnasset
Contributor

Thought so but having the issue on 10.8 machines too. It's strange, I can use the config profile and verify the boxes are unchecked and the SBAC browser thinks Spaces is still enabled. If I manually check/uncheck the boxes in keyboard shortcuts, then it works every time.

rspeed
New Contributor

Bumping this to see if anyone has found a solution for this. Thanks!

jared_young
New Contributor II

I did a Composer snapshot (new & modified snapshot), then made the changes for the mission control checkboxes, the keyboard shortcut mission control checkboxes and checking the box to turn F keys into standard. Packaged that change as dmg and deployed with FUT FEU. It kept 80% of the changes. The only thing that didn't stick was the Keyboard shortcut for Mission Control to move left or right in a space and this is critical to getting SBAC to work properly. It would be nice to have a granular system preferences configuration profile to turn on/off some of these features with Casper/JSS.

bcrockett
New Contributor III

I tried cbrewers script without any luck. The teachers at my site really detest this feature and my admin wants it disabled on all our macs.

Bumping this to see if anyone has found a non-imaging solution for disabling this feature. We have about 300 Macbook pro's and Macbook Airs running 10.11.5.

Thanks,

~ Buck

cbrewer
Valued Contributor II

@bcrockett I never had good results with the script above. Try setting this up using a user level Configuration Profile. See the following post...

https://jamfnation.jamfsoftware.com/discussion.html?id=9503