Microsoft Autoupdate Permissions Error

New Contributor III

Is anyone else seeing issues with MS Office Autoupdate on the latst couple versions of Big Sur?  This is recent for us.  Office installs via Jamf Pro, but when any account tries to run the Autoupdate they get a permissions error.  There is no config profile blocking permissions.  Even admins cannot run the updater.   This is happening on every new install of office for the last couple of weeks.  

Screen Shot 2021-08-12 at 9.08.59 AM.png

Have tried permission repairs with Disk Utility.  Tried the following:

sudo chown -R root:wheel /Library/Application\ Support/Microsoft/MAU2.0/Microsoft\
sudo chmod -R 775 /Library/Application\ Support/Microsoft/MAU2.0/Microsoft\

I downloaded the latest standard installer yesterday and it produces the same issue when installed via Jamf Pro.  

We have found 2 solutions:

  1. Download the latest version of autoupdate and run it on each user account.  Seems to need to be run on every user profile.  If you install from one account you cannot run it from another.
  2. Remove this simple autoupdate config.
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "">
<plist version="1.0">

I have played with different settings in the config profile to no avail.  I have to completely remove any changes to the plist or they cannot run autoupdate. 


The problem is, if I remove the config profile thousands of machines will get the stupid data use policy popup, so neither are good solutions. 

Any advice is appreciated.  


New Contributor

I found that I had to have a separate policy, after updating/installing Office 2019 v16.51.21071101, to install the MS AutoUpdater 4.37.21071101 as a standalone pkg.  After that, it worked as it should.


EDIT: Clarified version numbers and context


I also faced this issue after  MS AutoUpdater got updated on  August 10, 2021 (Version 4.38). 

I manually open the app  "/Library/Application\ Support/Microsoft/MAU2.0/Microsoft\ " and after that, I no longer see the error 

Contributor III

Yes I'm seeing it on both Office 365 installs and Office 2019.

Some say 'you do not have permission to open the application' and others say it 'can't run because it no longer supports the classic environment.'

On a one to one device a reinstall or manual run of the MAU will fix the issue.  But that's just for that one user account.  I'm testing 2019 on a student lab device and a log out / log in using a new standard test account results in the message coming back.  I might not install the MAU all together on student machines until this is resolved and push out office updates via patch management.

Valued Contributor

Are there a keys for making CP to block/disable auto-update AND Install button?



New Contributor III

We filed a bug with Microsoft on this, they said they are working with Apple.  The easiest fix is to navigate to the directory and open it from there, for some reason that works but opening it within one of the Office applications does not work.  Once you have navigated to the file and opened it, then it works just fine from any application.  You have to do this on every profile.  They have no official fix yet, just a work around.  


Any update at all on a fix from Microsoft?


@chelm do you happen to have a case# with Microsoft? I went to our o365 team, they contacted their rep, and they said they haven't really heard of it other than to reinstall Mau again, which is fine, but I'd rather wait for a fix before deploying a new version.  Any help would be appreciated.  Thanks.