Microsoft enterprise sso azure ad firefox and chrome

sunnysmbshare
New Contributor

Microsoft Enterprise SSO plug-in for Apple devices - Microsoft Entra | Microsoft Docs

Has anyone gotten this to work with Firefox or Chrome?  I only see examples where Safari works, but I have a requirement for the other browsers.

I've installed the latest version of company portal, made the configuration profile as explained in the link and added the plist file for the options:  browser_sso_interaction_enabled and disable_explicit_app_prompt.  I even tried adding the bundle names for chrome and firefox, but when I go to office.com I am greeted with a sign in prompt in the browser.  In the azure ad sign in logs, I don't see anything unless I go ahead and log in.

Edit:  This is working for chrome and firefox on our windows machines.

4 REPLIES 4

sunnysmbshare
New Contributor

here is what my configuration profile looks like

part 1 of configuration profilepart 1 of configuration profilepart 2 of configuration profilepart 2 of configuration profile

Captainamerica
Contributor II

Chrome is not supported with SSO on mac - information direct from Microsoft on Slack. Maybe at some point they will adapt the chrome browsers on mac to support the way SSO work on mac 

 

NOVELLUS
Contributor III

We struggle at this point, too. Chrome and Firefox doesn't work with SSO, but Safari and the MS-Office® apps do.

I worked out all the documentations, I found, but nothing works. Neither Chrome® , nor Firefox® 

sunnysmbshare
New Contributor

Thanks.  I just needed someone else to confirm that it currently isn't working.