Microsoft Outlook Error - EXC_BAD_Instruction - Outlook Version 15.33.0

New Contributor III

Hey everybody,

I've been trying for a week to get this Outlook to stop crashing on only one of our Mac computers.
I've done a complete uninstall, removed all Libraries associated to it and the error still persists.

I've tried to use a Fast Release and that didn't solve the issue either.
I've installed it from our Self Service again to make sure it didn't fail the first time and still a no go.

Any help would be appreciated.

I also thought I would mention, this has nothing to do with the crashes last week Microsoft outlook was experiencing with the Insider Fast.

----------------------- Error Report from the Microsoft Error Reporting -----------------------

Microsoft Error Reporting log version: 2.0

Error Signature:
ExceptionEnum: 2
Exception Code: 0x00000001 (0x0000000101cbe000)
Date/Time: 2017-04-24 19:52:05 +0000
Application Name: Microsoft Outlook
Application Bundle ID:
Application Signature: OPIM
Application Bitness: x64
Application Version:
Crashed Module Name: CoreFoundation
Crashed Module Version: 6.9.0
Crashed Module Offset: 0x0000000000115452
Blame Module Name: HelpshiftOSX
Blame Module Version: 1.2.9
Blame Module TimeStamp: 0x58e9ffa3
Blame Module Offset: 0x0000000000057a0f
StackHash: 6f7f
Application LCID: 1033
Extra app info: Reg=en Loc=0x0409
Crashed thread: 1
uncaught ObjC exception, reason: Key is missing or has been deleted

Last Exception Backtrace:
0 CoreFoundation 0x00007fff8acbf452 __exceptionPreprocess 178 1 libobjc.A.dylib 0x00007fff9b6e1f7e objc_exception_throw 48 2 HelpshiftOSX 0x00000001113fca0f HelpshiftOSX 358927 3 HelpshiftOSX 0x00000001113fcbe0 HelpshiftOSX 359392 4 HelpshiftOSX 0x00000001113e86f4 HelpshiftOSX 276212 5 libdispatch.dylib 0x00007fff95ef240b _dispatch_client_callout 8 6 libdispatch.dylib 0x00007fff95ef39f2 _dispatch_barrier_sync_f_invoke 74 7 HelpshiftOSX 0x00000001113e85ca HelpshiftOSX 275914 8 HelpshiftOSX 0x00000001113e1c6f HelpshiftOSX 248943 9 HelpshiftOSX 0x00000001113e7f2e HelpshiftOSX 274222 10 HelpshiftOSX 0x00000001113d7511 HelpshiftOSX 206097 11 HelpshiftOSX 0x00000001113d7391 HelpshiftOSX 205713 12 HelpshiftOSX 0x00000001113d6146 HelpshiftOSX 201030 13 HelpshiftOSX 0x00000001113d4f67 HelpshiftOSX 196455 14 libdispatch.dylib 0x00007fff95efd93d _dispatch_call_block_and_release 12 15 libdispatch.dylib 0x00007fff95ef240b _dispatch_client_callout 8 16 libdispatch.dylib 0x00007fff95ef703b _dispatch_queue_drain 754 17 libdispatch.dylib 0x00007fff95efd707 _dispatch_queue_invoke 549 18 libdispatch.dylib 0x00007fff95ef240b _dispatch_client_callout 8 19 libdispatch.dylib 0x00007fff95ef629b _dispatch_root_queue_drain 1890 20 libdispatch.dylib 0x00007fff95ef5b00 _dispatch_worker_thread3 91 21 libsystem_pthread.dylib 0x00007fff998c24de _pthread_wqthread 1129 22 libsystem_pthread.dylib 0x00007fff998c0341 start_wqthread + 13


New Contributor II

I have been running across the same issue with MS Word on El Cap machines no matter if I run the .pkg directly from Microsoft or through the Self-Service tool. I have yet to find a solution online for this issue.

Contributor III

Try deleting the login keychain.... I had that issue b4 and it fixed it for me

New Contributor II

Try this.

security delete-generic-password -l "Microsoft Office Identities Settings 2" login.keychain
security delete-generic-password -l "Microsoft Office Identities Cache 2" login.keychain
security delete-generic-password -G "MSOpenTech.ADAL.1" login.keychain
security delete-generic-password -l "Exchange" login.keychain
security delete-internet-password -s "msoCredentialSchemeADAL" login.keychain

New Contributor III

We've ran into this issue on a Sierra computer running 10.12.4. Will try these fixes, thanks guys!


A few things to try. Delete/recreate the user account. Downgrade to previous patch. Talk to microsoft (lol). Last resort reimage. Also don't post huge crash logs.

New Contributor III

(Sorry about the long log, I deleted the threads.)
I've deleted the user cache, the application cache, the entire apps, anything related to Microsoft on the Mac. That didn't solve the issue.

I'll let you guys know if what app2pack posted works.

New Contributor II

Check for multiple MSOpenTech.ADAL.1 in keychain access. You need to remove each of them.

New Contributor

Microsoft has shown interest in figuring this out. If you have contacts or the ability to open a ticket, do so to help the greater good.
They suggested searching for 'helpshift' in the Keychain and removing any entries for that and relaunching the application.

HelpShift is used for the "Contact Support" functionality.



Does this happen under a different user account on the same machine?

New Contributor III

I have still not found a fix for this issue either. It is only currently affecting one of our machines though. The user has been using the web app without issue. I've looked through the keychain and there is an exchange password for their email, skype for business password (which works), but nothing else related to Microsoft and none of their Office 2016 for Mac suite will open. I haven't been able to devote a whole lot of time on this but I'm still looking into it when I have a chance. Thanks for your input and hope you get your issue resolved @dcappelle.

New Contributor II

I have opened a case with our Microsoft representative to see if we can get some insight to what is going on.

New Contributor III

Hey guys, I have some updates for you.

Try this.


security delete-generic-password -l "Microsoft Office Identities Settings 2" login.keychain security delete-generic-password -l "Microsoft Office Identities Cache 2" login.keychain security delete-generic-password -G "MSOpenTech.ADAL.1" login.keychain security delete-generic-password -l "Exchange" login.keychain security delete-internet-password -s "msoCredentialSchemeADAL" login.keychain

One of those commands worked - security delete-generic-password -l "Exchange" login.keychain
No changes in Outlook, still crashes.

I did not test a different user, I will later tonight when the user is not on his computer.

helpshift was not in the keychain. I didn't want to delete the entire keychain yet.
MSOpenTech.ADAL.1 also was not in the keychain.

This computer is running 10.11.6, not Sierra.

New Contributor III

Another update! I was working with our guy that would put in a Premier ticket for us to Microsoft. He found a new forum where Microsoft is acknowledging the issue.

Here is the thread for it:

It was only posted last week.

There are a couple solutions in it (Deleting the Keychain has not fixed their issue) that may have worked.
I'm going to test them, then report my findings to you guys.


New Contributor III

Thanks for the heads up on that thread @dcappelle. I posted on it to see if I get a response. We are primarily Mac so we don't have a Microsoft contact. I'll post if I get a response, however, it looks like most of the fixes in the thread have already been tried. Thanks again!

Contributor III

@dcappelle @egill I had the same issue on my Mac where Outlook was crashing at every launch with an entry in the crash log that showed the Blame Module was HelpShiftOSX.

In my case I found it was due to the fact that I had created a second Keychain, we'll call it "Test", located somewhere else other than ~/Library/Keychains/ AND set that "Test" Keychain as my default AND I deleted all HelpShift entries, since I didn't know what they were for at the time, from the login keychain. When ALL of those conditions are met I get a consistent crash. It appears the problem is that for some reason in that specific state Outlook can't recreate the HelpShift keychain entries and crashes.

In the hopes that it will help, here are the steps I came up with to consistently recreate the issue on a clean test Mac.

Instructions for replicating
1. On a clean Mac, open /Applications/Utilities/Keychain Access.
2. Select File>New Keychain…
3. In the new Keychain window, name the keychain something like "Test". In the "Where:" drop-down list, select Desktop. This is very important because when leaving the new keychain in the default Keychains folder the problem does not occur.
4. Click Create….
5. Enter a password for the new keychain and click OK.
6. Right-click on the newly created Test keychain and select Make Keychain "Test" Default.
7. Install Office 2016. If you have access to the standalone Outlook 2016 installer you could just install Outlook.
8. Launch Outlook 2016.
9. Notice it will show the Outlook first run/welcome window without any issue. Click Get Started. Click Continue>. Click Start Using Outlook. At this point it will crash.

Steps to fix the crash
1. In Keychain Access, right-click on the login keychain and select Make Keychain "login" Default.
2. Launch Outlook 2016.
3. Notice that it no longer crashes and displays the Set Up Your Email window.
4. Walk through setting up an Office 365 account.
5. In the login Keychain, there will now be four HelpShift entries.

Of note, now that the HelpShift entries exist, you could switch back to using the "Test" keychain as your default keychain and Outlook will launch without crashing since the HelpShift entries exist. In this configuration one of the HelpShift entries actually disappears leaving you with only three entries. If you delete the HelpShift entries at this point the crashing will occur again and you will need to walk through "Steps to fix the crash" again.

I have been in contact with Microsoft Support and they are able to recreate the issue using these steps, so hopefully they will have a fix soon.

Contributor III

Hello, does anyone know if latest "insider fast" 15.36 (170524) fixes the problem?
I could not find a fix other than reverting to 15.32
Mnay thanks to all