Mojave - AnyConnect Issues

New Contributor III

We use Cisco AnyConnect Secure Mobility Client for corporate network access. We have Macbooks that have upgraded from High Sierra to Mojave and no longer able to access corporate network (wired or wireless). Post-Mojave upgrade, systems are failing system scan with "Failed to launch downloader". I understand this is not a Jamf issue but was reaching out in the event anyone has heard of this issue. After uninstalling and reinstalling AnyConnect, we get system scan error "Failed to load compliance module". Any information on what may have changed in Mojave that would impact how a machine postures on the network or any advice based on experience anyone has heard would be appreciated. Attached are the screenshots of the errors. TIA for any help.db508969dd324be9b2a71578f1455045


Valued Contributor

Aside from checking for a newer version of AnyConnect, you might be running into issues with the new Privacy Preferences Policy payload

New Contributor III

The don't think the compliance module supports 10.4 yet.

Contributor III

I would review the information here

We have no troubles with just the VPN component


for us everything works fine, but we only use the VPN module (and we also install DART per default).

New Contributor III

I appreciate the suggestions everyone, especially since this isn't a Jamf issue (issue still happens on an a device not enrolled in management). I have a network engineer looking at the issue on their end but the Jamf community has always been a big help with things like this. I have tried AnyConnect versions 4.2 up to 4.6.03049, none working. I originally thought it was an issue with 32bit support in Mojave but I confirmed the AnyConnect packages I was using were 64bit. There was also a concern with GateKeeper in Mojave however we have that set to allow apps to download from Anywhere so that shouldnt be causing any problems.
I would be curious about the compliance module support for 10.14. I'll do some digging on that. Thanks for help thus far!

New Contributor III

I was able to get passed the "Failed to load compliance module" by manually installing the new compliance module but now I get "this operating system is not supported by the server" error while AnyConnect is performing a system scan. Makes it to 10% of the scan but then fails with that error.


I have no issues with Cisco AnyConnect 4.xx and Mojave. But I also only use the VPN module. Must be the System Scan module not been still compatible. But the release notes of latest Anyconnect dont say anything
Hope you find a solution soon


we had the same issues, however my network team did an update to the compliance model to support 10.14

New Contributor

I have faced the same issue with CiscoAnyconnect 4.4 version in Mojave, reinstalled with 4.5 and it is worked.