Mountain Lion - Imaging Error

ajezard
New Contributor

Hey Guys,

Can anybody tell me how or why Casper Imaging comes up with the following error when imaging via Mountain Lion ?

"An exception of class NilObjectException was not handled. The application must be shut down."

12 REPLIES 12

vk1068
New Contributor

Hi, I find if I uncheck the erase HD option I don't get the error. However this is obviously not a solution.

jhbush
Valued Contributor II

The first thing is what version of the JSS are you running? If you are running 8.6 then let us know what your imaging workflow looks like. Generally you see this error if the version you are using is incompatible with the OS you are trying to image.

brownd
New Contributor

I am having exactly the same issue. Have updated to 8.6 and still received the same error.

brj
New Contributor
New Contributor

Follow the instructions on the following webpage and this should fix the issue - http://www.macos.utah.edu/documentation/administration/setup_netboot_service_on_mac_os_x_10.6.x_client.x_client/setup_netboot_service_on_mac_os_x_10.6.x_client-diskless_netboot.html

ega
Contributor III

I can confirm this issue with jss 8.6.0 and that ... setup_netboot_service_on_mac_os_x_10.6.x_client-diskless_netboot.html DOES NOT FIX the issue.
I have made 3 different netboot sets for 10.8 and tried them with and without Utah netboot.rc mods. Last time I saw this issue had to apply a combo updater over top of a clean install then create the netboot set. Bad news is there is no combo updater at this writing for 10.8. Anyone have any luck netbooting OS X 10.8.0. For the record same iMac (4 gig ram) and other test mac mini(4 gig ram) machines netboot to 10.6.8 and 10.7.4 .nbi's and run casper imaging with no problems.

brownd
New Contributor

I updated my JSS to 8.6 my Netboot Server to 10.8.1 and my image is 10.8.1.

After following the instructions that brj suggested it now works. I will also add that I did not modify the rc.netboot file but downloaded the file at the end of the instructions and replaced it.

ega
Contributor III

So follow up. I did discover an error in my modified rc.netboot that caused the ramdisk to NOT be used. I fixed that issue and works as described in the Utah web page. Note that my netboot servers are 10.6.x and the netboot image is 10.8.0.

greatkemo
Contributor

@ega You should give it to @brj and and check this off as being answered.

sns
New Contributor

We have been getting "An exception of class NilObjectException was not handled. The application must be shut down." error in Casper Imaging 8.61 and still now we are running 8.64 and we are still getting the error. @Ajezard could be right that this occurs in Mountain Lion.

Our JSS server is running on OS X 10.8.3 and our images are also OS X 10.8.3. Our netboot server once live in OS X 10.8.2 now 10.8.3 but since the NilObjectException error is constantly appearing, JAMF techs have suggested using NetSUS appliance to resolve this error. However I tell you that even the NetSUS appliance as a solution to netboot triggers the NilObjectException error.

AFP permissions are correct, diskless booting was checked for the NBI creation, I also have edited the rc.netboot file as suggested by @brj. Update after update of the JSS yet this issue isn't resolved. Last week we did not get the NilObjectException during imaging. Our first imaging this week triggered the NilObjectException. We were running JSS 8.63 then. Updated the JSS this week in hopes to have a fix then moved from using OSX for netboot to the netsus appliance. But still NilObjectException error still there. This morning we imaged a machine netbooting to the NetSUS appliance running casper imaging 8.64. The imaging process completed without errors. Except the imaged machine was missing the printers that were compiled with the selected image configuration. So I re-imaged again but can't, cause now the NilObjectException error is back. The NilObjectException error shows up before Casper Imaging window comes up. This is before a configuration is even selected. It would be nice to know what is being done while the Casper Imaging splash screen is displayed prior to loading the compiled configurations. This way we can isolate and debug the cause of the error.

I do want to know what triggers this error and why is it intermittent?

nethers
Contributor

Make sure your OS Image 'dmg' is set to priority 1. I had changed mine to 10 and forgot to save before moving to a machine and imaging it. This resulted in the nilObjectException error.

AlanSmith
Contributor

Just to resurrect an old post, I too have started getting that error!

My set up is:
Mac Mini Server running Mac OS X v 10.9.1
Brand new iMac (shipped with 10.9 - can't run 10.8.5)
Netboot image running 10.9
Trying to install a Base image of 10.9.1

JSS is running 8.71
Casper Imaging running 8.73 (yeah, I know)

And the only thing that stopped me getting the error was unchecking Erase Macintosh HD! I have a couple of Labs of these new iMacs to image and I need to be able to erase the HD as part of the process.

Any ideas - I will endeavour to upgrade the JSS to 8.73 in the meantime.

Cheers

Randydid
Contributor II

Alan,

I have this on a 27" iMac, 8GB Ram, 1TB HD. I am bumping this too. My NBI is 10.9.2, latest version of Casper. 9.31. I too need to erase the HD as part of our lab image process.

TIA!

/randy