mountNetworkShare.sh Volume hidden

TimT
Contributor

Hi All,

I've been using the above script to mount network share using kerberos for some volumes. We are using a Sun server that uses username/password for authentication. I have made the appropriate changes in the script to use username/password however the share doesn't mount on the desktop. When I reveal all hidden files in the Directory I can see the share in /Volumes but it's mounting on the Desktop.

I have checked other threads but can't work out why this is happening and how to rectify it.

Any suggestions would be appreciated..

Thanks

T

4 REPLIES 4

jarednichols
Honored Contributor

Is it just the Finder preference that by default hides mounted shares?

TimT
Contributor

Hi Jared,

No, Finder prefs have connected servers checked and the shares that use kerberos authentication appear on the Desktop. When I run the command to show hidden files I can see the volume along with the other volumes except this one's not appearing on the desktop.

mm2270
Legendary Contributor II

Can you clarify what you mean by "When I run the command to show hidden files I can see the volume along with the other volumes"
Where are you seeing it? In the /Volumes directory? On the Desktop?
Does it show up in the sidebar at all with an unmount icon? Lastly, can you browse through the volume when you view it showing hidden files as you indicated above?

Something tells me it may not actually be mounted even though you're seeing it, But there are other possibilities as well.

TimT
Contributor

I have run the script via policy triggered by login.

I had read but cannot find that certain shares will "mount" but not be visible unless the defaults write com.apple.finder AppleShowAllFiles TRUE command is run.

It doesn't show up in the sidebar like the other shares and yes I can browse through the folders on the share so it's quite strange. It's mounted yet not quite there.

The share in question then appears in /Volumes/shareName. The

I probably should have added that the share resides on a Window server which shares out via Extreme-Z IP. When I tweak the script using smb instead of the preferred AFP i.e share='smb://server/shareName' the share mounts on the Desktop. However due to issues regarding SMB shares we prefer to use AFP and utilise Extreme-Z IP.
The shares that are mounted using kerberos authentication also via Extreme-Z IP are fine. Its only when authentication via "username/password" that this particular share doesn't mount on the Desktop.

My scripting knowledge is not great but the issue appears to point to the authentication as kerberos authentication works beautifully.

Cheers
Tim