MUT v4 RC3 is now available!


Big news for The MUT: I am wrapping up development of MUT v4. The RC3 can be downloaded from the Beta URL located on the Third Party Products page located here:

MUT v4 comes with a pretty significant UI update, which I would love to get some external input on. I've had quite a few folks internally checking it over, and reactions seem positive. The goal is to be able to give the tool to someone who has never used it before, and have them be able to just run with it, without the need for support/help, while not making it any more frustrating to use, or less powerful for experts.

New Features:

  • Ability to change tvOS AirPlay Passwords (Mobile Devices > tvOS AirPlay Password)
  • New Login Window which simplifies the login process, and de-clutters the main window
  • Combined the "full url" and "cloud instance" boxes, with a logical switch to determine what is in the box
  • Unique Identifier determined logically:
    • If Column A is comprised of only numbers, MUT will assume an identifier of "ID"
    • If Column A contains letters (other than the header row, unless there is ONLY one row) MUT will assume an identifier of either Username or Serial depending on the records being updated
    • This logical determination can be overridden by use of an optional header specifying "serial", "id", "username" etc.
    • My tests of the logic have been sound so far, but I recommend paying extra attention to the pre-flight checks for your first few runs. They will tell you what logical determination MUT made, and whether or not that determination was overridden by a header
  • Overall UI update to simplify the tool and make it more user-friendly, while not removing the power and while not involving extra clicking
  • The log box will now supply sample CSV output upon first launching the app
  • Cleaned up much of the pre-flight and run time code, which will hopefully alleviate crashing
  • Clarified some messaging to help end-users help themselves a bit better

I'd love a bit of feedback on this, including any situations where you find that my logic checks break down ("eg: If I have a CSV that says such and such, it does not determine the identifier properly"). I've obviously done a ton of testing, but I don't have a QA department, and would love your input.

Once I've had a few people reporting success, I'll be pushing this version out, along with updated documentation and how-to videos.



New Contributor III

404 Error
The URL requested does not exist. when I hit that URL


@ober fixed. I'm not sure why, but it was appending some spaces and a line break at the end of the link.

Should be resolved now. Otherwise, a direct link to the download can be found here:

New Contributor III

Hey Mike,

First off, thank you, thank you, and thank you again for The MUT. A good deal of my workflow wouldn't be possible without it!

I couldn't find another way to contact you to share a bug I encountered, so I'll post it here. I was trying to import some names into the Room field of some records yesterday (don't ask), but The MUT kept crashing, and it took me a while to figure out why. I blame a user named Zoë.

It seems saving my Excel spreadsheet as a standard .csv changed the "ë" in her name to a " ‘ ", which was subsequently crashing The MUT when it tried running a pre-flight check on said .csv.

Now, in the course of trying to find a way to contact you, I've discovered your advice on using Windows Comma Separated (.csv) for Excel exports, and that works just fine! I'll certainly do that in the future. It might still be handy if the program could issue a warning about invalid characters when it encounters them, though.

Cheers, and thanks again,

Contributor III

@mlev I am Trying to use JAMF MUT v4.0, but it says it found more than two columns in the .csv. The forst column shold be your unique identifier (eg: serial) and the second should be the value to be updated.

The first column has the SN, second has the Asset #. There are no other columns that I can see in the .csv file. Any help would be greatly appreciated... I need to get this out today and this is the first time I have had any issues with the mut. it is a great tool.


@rhooper If you cat the file, what do you see? Pop open terminal and type "cat " (cat space) and then drag and drop your CSV file into terminal and hit enter. If it looks funny, try the stuff below:

Did you make the CSV in Excel? If so, try either "Windows Comma Separated" or "MSDOS Comma Separated" format, depending on your version of Excel. The regular "mac comma separated" or just "Comma separated" can have some weird line break formatting that MUT (and the cat binary) don't really like.


@mbeckett glad to hear you're liking it!! Yes, getting things to play nicer with special characters and different character encodings is on my list of goals for 4.Soonish. I've had some requests for Japanese character support for example.

I believe some of this is going to be impossible to overcome due to limitations on the API side of things, but at the very least better error catching and reporting would be good, instead of just a straight up crash with no real verbose messaging.

Contributor III

4.soonish.... ? that is a new version denotation???? LOL

I found a Windows machine and saved the files as MSDOS CSV format, and it works well... I think the MSDOS is an UTF8? Anyhow, thanks for the quick response, I Am looking forward to v4.soonish....

Thanks for your hard work on this tool.


Excel on Mac should have the option to do msdos csv under the save as menu, and I believe you are correct about the formatting.

I figure people use “” so why not “4.soonish”!? Ha!

Valued Contributor

Are logs located anywhere? Trying to run a user position update on quite a lot of users. It starts off okay but MUT will randomly crash at a different user each time. Not sure where the logs are located. Would use the log from the interface but as MUT crashes, I lose access to this log file.


I am not able to change IOS device names with the tool. Attempted multiple times moving the columns but still not working. It picks up the layout with pre-check, even gives an "OK!" but still no change to the ipad device name. Thoughts?

Contributor III

Check to see if you have enforce name checked or a config profile restricted the ability to change device name.


@m.donovan Yes, we have it enforced in the pre-stage enrollment. Dang, so I would have to disable manually on each device just to be able use the tool. Not fun! Come on JAMF, give us some more robust bulk editing tools!



MUT updates Mobile Device Names a bit differently than it updates any other field. In order to enforce the name change so that it sticks, MUT will actually generate an MDM command on the device to update the name.

This MDM command requires that device name changes are not blocked (restriction payload on a configuration profile), and they also will not actually take effect until the device processes the MDM command.

If another name change is submitted via MUT before the first name change command actually processes, you will receive a 400 error, and it will state that the command is already pending under Advanced Debugging. You can see this pending command on the management section of the device record.

To get the name changes to actually take effect, the device has to be turned on, on network, MDM capable, talking to Jamf Pro, and all that jazz—as soon as it processes the MDM command that's pending, the name will update.