MySQL 5.6.22

Contributor III

Did anyone upgraded database to MySQL 5.6.22. Its working fine everywhere except the JSS Startup --> Generating self service notification is stuck at 46%. I can connect to it with users 'root' and 'jss' and query tables, list tables etc. In the Jamfserver log file its giving error that the TABLE: jss.mac_os_x_enrollment doesn't exist. I have tried reinstalling jss installer and MySQL but no help.


New Contributor

I cant download anything

Valued Contributor II

I just install it for new test environment, from scratch and a clean JSS install worked fine.

New Contributor III

We just moved our database to it's own server and went from 5.6.17 to 5.6.22. So far we haven't had any major issues with it. You may need to fix some of the tables in the database. I don't know enough about the mysql commands so you may need to get ahold of support or if you do a manual backup that will try to fix any issues.

Release Candidate Programs Tester

Check out rtrouton link to do a mysqlcheck and restart the JSS when it gets stuck.

Had the same issue after upgrading to 5.6.21. I used a slightly different command of mysqlcheck to repair the tables.

/usr/local/mysql/bin/mysqlcheck -u root -p --auto-repair --optimize jamfsoftware

This is a pretty extensive process and might take a while. After that I just used the JSSDatabase Utility and restarted tomcat.

Contributor III

Thanks guys. It wasn't the MySQL upgrade issue from 5.6.17 to 5.6.22. It was actually the JSS upgrade path issue.
We followed the path from JSS 9.31 to 9.4 and then to 9.62 and all is well.
However, because we tried upgrading from 9.31 to 9.62 which caused us reverting the JSS installation (bit of a pain but learnt some new stuff). For upgrading I would always suggest to go by series like from 9.31 to 9.4 to 9.5 etc rather than jumping from 9.31 to 9.62.

Contributor II

We had some similar issues when moving to 9.6x. It turned out we had a couple of records with some bad data that it was stalling out on. Once those were deleted we were able to upgrade just fine.

On the MySQL 5.6 topic we recently I found that some of our MySQL problems were being caused by a bug in MySQL 5.6.13 and higher. The main times I saw this was when using the JSS Database Utility. My backups would not run consistently or I would get messages that I could not connect to the database from the utility.

A description : "Under heavy workload mysql 5.6.16 (replicated on 5.6.13 and higher) throws connection errors "Lost connection to MySQL server at 'sending authentication information', system error: 32". This was tested on OSX 10.8 and 10.9. The issue is not seen on windows or other unix servers like centos."

A further description of this issue :

JAMF Support had me add the line : table_open_cache = 512 to the my.conf file

It totally fixed the issue. My guess is that you might not see it on a JSS that doesn't have as many clients or isn't that busy. Ours has about 8,000 computers and 2500 mobile devices so the database is fairly large. And it is busy.

The other solution is to go back to MySQL 5.5.x. I didn't really want to move backwards so I went this this fix for now. It seems to work fine so I'm going to run with it for now. Hopefully they will fix the bug at some point and then maybe I'll look at upgrading MySQL.

Contributor II

Just noticed that all the latest MySQL releases are 5.7.x

Anyone tried these yet with Casper ?

Contributor II

MySql 5.7 not yet supported by jamf