Netboot Imaging with Fusion Drives and 10.13.6 - doing my head in!


OK, so I feel like I am going around in circles here and nothing I have come across seems to replicate the same issues I am having - all slight variations.

So the back-story:
We have a number of labs to re-image at the start of each year. Due to software compatibility we tend to run one macOS behind the current one. This year we've been running 10.12.6 and are looking at moving to 10.13.6 for our 2019 academic year.

We have also had some new iMacs arrive that will be deployed to some of the labs - but not all! The new iMacs have Fusion Drives.

We are on JamfCloud running JSS v10.8

Now in the past when I have wanted to update our BaseOS, I usually install the current working one and do an in-place update, create a new DMG from the result using DiskUtility and booting from an external drive. Occasionally I have had to do a clean install of the OS we are wanting to move to - then configure it how we like, create the DMG from that. Regardless, I then take the new DMG and place it a deployment Configuration in JamfAdmin - do a complete NetBoot re-image on a machine and everything has worked out nicely.

However this time round, when the iMac has finished imaging and rebooted the machine would start to boot - Apple Symbol --> Progress bar and then when it is at about 75% I would get the 'no entry' circle with a line through it come up.

So I did some reading and thought, perhaps using DiskUtility to create the DMG is not the way to go with the new File System - maybe I need to use AutoDMG. So I tried that and it 'kind of' worked insofar as, I got a base OS installed, but instead of booting to it, the machine would then boot into RecoveryMode, and once I had selected the Startup disk, then it would boot to the very basic BaseOS (initially no admin account - added later via Jamf Imaging) Default Dock, System Prefs not set how we like etc.

However this was still not suitable for our environment.

I then did some more reading and thought that perhaps I needed to break the Fusion Drive, reformat the Macintosh HD to HFS+ and then create a BaseOS DMG.

Still no joy - getting 'no entry' circle again!

I tried erasing the destination disk using Disk Utility before running Jamf Imaging - and that took me to the Recovery Partition after reboot again. Then when I tried it a second time I got the 'no entry' circle again.

I'm really at my wits end as to what I 'should' be doing. APFS vs HFS+, Fusion vs Split Drive vs CoreStorage.

I need a workflow that is simple, reliable and consistent.

I know we will need to move to a 'DEP' based solution and we are in the process of doing so, however I do not have time to figure exactly how that all works at this stage.

So in summary:
JSS 10.8 via JAMFCloud
Netboot Imaging
A mix of Fusion Drives and non-Fusion drives
BaseOS of 10.13.6
Have tried both DiskUtility, AutoDMG & Composer to create BaseOS DMG.
Have tried both HFS+ and APFS DMGs
All either boot to 'no entry' circle or Recovery Mode

Oh and most of the discussions I have seen about similar issues are from earlier versions a few years ago.
All and any guidelines would be appreciated before I lose what little hair I have left.


Valued Contributor

Not sure if I misunderstood this from your post, but using a NetBoot install to upgrade your lab is not supported by Apple with High Sierra. I know there's times where Apple says its unsupported, and it still works anyway, but this is the double whammy of not supported and mostly broken. Apple's guidance is you can only do a NetBoot install (whether thats through something generated by AutoDMG, or your own custom system) on a system that's already been upgraded to High Sierra.

In addition, I don't believe NetBoot DMG restoration workflows are supported on APFS, or if it is, its very unreliable. From reading JAMF Nation I believe most admins wanting to do this are still using JHFS+. If you are deploying to Macs with Fusion Drives, then JHFS+ is the only supported file system by Apple there as well. APFS for Fusion Drive and regular Hard Drive systems is only supported on 10.14 Mojave.

If you search around JAMF Nation, some folks have come up with some interesting ways around these limitations. If you do need to "image", my recommendation would be to add some extra steps into your workflow, and upgrade the lab machines to High Sierra first using some of the tips in this article using the installer app:

You can't erase a 10.12.6 system, but you can do an in-place-upgrade. Once you get your systems up to 10.13.6, you should be able to then image them with a 10.13.6 image that you made using your normal methodologies. You'll end up running into some other issues after imaging with user-approved MDM since systems are not going to be enrolled via DEP automatically.

Personally, I gave up on imaging and focused my energy on migrating to DEP when I started running into a lot of these road blocks.




Hi Ted

Thanks for that info - very helpful!

A couple of clarifications around the upgrade first then image process.

Once a machine has already been upgraded to 10.13.6, it can then be erased and imaged with 10.13.6? (I take it this is due to firmware requirements of 10.13.6 needing to be in place first?)

Any pointers on why a machine would reboot into Recovery Mode at the end of the Jamf imaging process when it is specified to reboot to the target disk i.e. Macintosh HD?