NetSUS Appliance on Hyper-V


Just wondering if anyone has had success getting the NetSUS appliance running on a Hyper-V VM?


We are using Hyper-V to host Win2008 R2 servers in our environment. Our JSS is on one of these VMs and running quite happily. We have a lone Xserve and I am thinking about end of life for it and where we will go when that time comes. To that end we've been working on getting the NetSUS appliance running as a Hyper-V VM.

We have the VM starting and we can log into it both as shell and as webadmin and do basic management stuff, however, SUS does not sync and I cannot upload an NBI.

On trying to connect to the SMB share to upload the NBI I realised that the Netboot share does not exist.

When the VM boots the first line in the console says 'no such disk.'

We think that this has to do with the type of boot disk that Hyper-V machines must use being different to that used by VMware/Virtual Box.

Ideally we want to host the NetSUS on a Hyper-V hosted machine because of the DR already built into our system and to keep the NetSUS as much in line with the rest of our systems as possible.

Anyone got any great ideas out there?




New Contributor II

I've never tried this, but could you just install Ubuntu Server and then use github in some way or another to install the NetSUS package? JAMF might be able to help you do something of this nature. You may have to end up installing some prereqs before hand, but it might work.

New Contributor

Has anyone tried this?

New Contributor III

I used disk2vhd to convert the VMware disks to Hyper-V. I couldn't NetSUS to work as it had no NIC. 10.0.4 of Ubuntu seemed to have a lot of issues with Hyper-V from what I could Google.

Contributor III

I was able to successfully convert it a month or so ago.

I am just now getting it setup to test netbooting/performance.

IIRC I extracted the VMDK out of the provided OVF and used Citrix XenConvert to get a vhd out of the VMDK.

New Contributor

Ubuntu 10.0.4 has some pretty major network issues in Hyper-V. In order to get this working well it will need to be developed on a RedHat-like base (RedHat, Fedora, CentOS).

New Contributor

If someone got the time to create a working HyperV appliance, can you please share?




My co-worker just converted ours to HyperV and it appears to be working... here is his documentation for what worked for him:

Source Files To start, you will need the latest Ubuntu 12.04 server ISO from here: Second, we will be using JAMF’s seed file with a minor modification to support Ubuntu 12.04: Seed File The seed file works fine for Ubuntu 10.04, but the mkpasswd package is no longer available in 12.04 which will cause the automated install to fail. When setting up by hand, apt claimed noted that mkpasswd had been merged into whois. Though whois is unrelated to mkpasswd, it will stay in that package at least for 12.04 according to Ubuntu’s bug tracker (see Open the seed file, find mkpasswd and replace it with whois. Now put the .seed file somewhere on a web server, and then we just reference it during the install. Install To start, we create a VM in HyperV and insert the Ubuntu 12.04 ISO. When we first turn it on, it will boot from CD and start the text based install. Here are the steps to kick off the install: 1) Hit F6 which should bring up the advanced options 2) Hit Escape to get out of the advanced options menu a) This should leave you with a text string at the bottom ending with -- 3) Go to the end of the text string and add install auto=true priority=critical url=http://webserver/NetSUS-1.02.seed a) It should look like this: 4) Hit Enter and it should kick off the automated install without issues Finishing Touches There are two main issues that we have internally that have to be addressed: proxy authentication and netboot name. When all is up and working, we will change the passwords. Proxy Setup The two applications that we made changes to were apt and reposado. For apt: 1) sudo nano /etc/apt/apt.conf.d/proxy 2) Add Acquire::http::Proxy "http://username:password@our.proxy.address:80"; to the end 3) Save by pressing Control+O 4) Exit by pressing Control+X For reposado: 1) sudo nano /var/lib/reposado/preferences.plist 2) Add the following: <key>AdditionalCurlOptions</key> <array> <string>proxy = "our.proxy.address:80"</string> <string>proxy-username = “username:password”</string> </array> 3) Save by pressing Control+O 4) Exit by pressing Control+X Change Netboot Name The netboot name is stored in hex within the DHCP conf file. The name needs to be converted from ASCII to HEX and formatted as AA:BB:CC:DD:EE:FF. It appears there may be a limitation where the first word can only be 4 characters long, but I haven’t had a chance to confirm yet. 1) sudo nano /etc/dhcpd.conf 2) Change 46:61:75:78:20:4e:65:74:62:6f:6f:74 to your value 3) Save by pressing Control+O 4) Exit by pressing Control+X You will need to restart the service (or the VM as I did) to change the name.

Honored Contributor

This needs a KB article pronto. Erin??

New Contributor

Not to bring back a discussion from the dead, but when trying this on Hyper-V 3.0 (Server 2012), the VM hangs at a black screen out of the box using the NetSUS-1.02 seed file. I can get around this by booting in recovery mode from GRUB, and then it proceeds just fine, but that's kind of annoying. Has anyone else had this issue?

New Contributor

@c_lawrence: Sorry I didn't see your message. I work with Andrew and wrote the documentation on this. The issue with Hyper-V 3 and above is that the video mode being used is not supported from console. I'm sure there is a graphics mode that fixes this issue, but I just disabled the graphical terminal. Here are the directions I've added to our documentation. Also, I have tested this on 13.04, and everything seems to work exactly the same as 12.04.

At the GRUB bootloader, press e while Ubuntu is highlighted to edit the boot option
Delete the line gfxmode $linux_gfx_mode and press Control+X (or F10)
Log in as shelluser, then sudo nano /etc/default/grub
Uncomment the line GRUB_TERMINAL=console
Press Control+O to WriteOut, then press Control+X to exit
Finally, run sudo update-grub to updated GRUB with the change

New Contributor III

any chance for the new NetSUS 2.0 seed?