NetSUS Cannot connect to SMB share

Contributor II

I have set up NetSUS running on Ubuntu 14.04.5 LTS, but I cannot figure out why I am not able to connect to its SMB share to upload the Netboot image.


I have verified that the firewall on the server is off.
I have double checked the user account.
I have double checked folder permissions are set correctly.

It doesn't even look like its trying to authenticate with the smbuser. But the smb logs are not showing anything and I am stumped.

Config file shows:

[NetBoot] comment = NetBoot path = /srv/NetBoot/NetBootSP0 valid users = smbuser write list = smbuser create mask = 0755 browseable = No

Folder Permissions:

drwxr-xr-x 2 smbuser root 4096 Oct 7 2016 NetBootSP0


Contributor II

I'm having a similar issue. It throws this error because it appends some other IP address to the actual IP address:

This server has a FQDN in our DNS servers, and it has a reservation in our DHCP server so it always gets the same address. I don't know what's going on with it, but it's annoying AF.

Contributor III

@itupshot, were you able to get this working? I'm getting the same error message. I also tried to connect via AFP and that connected, though it doesn't show any files.

New Contributor

I just set up the NetSUS on Ubuntu 16.04 today, and I'm stumped here as well. Can't figure out how to get SMB access working.

I tried to manually copy a .nbi created with AutoDMG/AutoCasperNBI to /srv/NetBoot/NetBootSP0 and it isn't being recognized, either.

New Contributor III

I'm having a similar issue. If I manually connect to the smb share from Finder, I can connect. It's only when I try to use the Netboot upload tool that I get the "There was a problem connecting to the server error.

What I'm wondering is whether or not it's possible to back uninstall/reinstall the NetSUS scrip or if maybe I can just rerun the installer and get the server set back to it's default.

In my case, not only have I had a couple of different people working on this but I'm not sure which config files NetSUS actually uses. From the NetSUS GUI, I show two file shares. I installed WebMin and it doesn't show any shares. Further, when I issue "smbstatus --shares" I don't see either of the shares I've created. (I'd expect to see NetBoot and SUS) and I'm not seeing either of those.

I appreciate anyone who can point me in the right direction.

Thank you,


I have had this issue in accessing it from a Mac running Mojave. I tried the same thing on one of my other Macs still on Sierra and had no issue. My solution is to create a VM running Sierra and use that until all of my older Macs are off of Sierra and just doing an Erase/Install of a clean version of High Sierra.

I think it is a Mojave issue in connecting to the share. I have not yet found a reason why.

Valued Contributor

Try to SSH into the server itself, and reset the smbuser password with this command:

sudo passwd smbuser

Go through the prompts and change the password. Then go back to the accounts section of the NetSUS web interface and change the password there as well and use the new password you've chosen.

New Contributor II

When I click the +Upload button in the "NetBoot Server" part of the web UI, it tries to connect to some share in the Finder, which does not work.

When I manually connect to the NetBoot share in the Finder, it all works. I do that in the Finder's Go Menu -> Connect to server… -> smb:// I just copied my 3 NetInstall and 1 NetBoot image into that share, and after that they showed up in the web UI.

BTW it's awesome that one no longer has to manually edit the dhcpd.conf file to get multiple images to work in parallel. ;)

I'm trying to set up my NetSUS 5 VM (created from the appliance OVA) using Ansible, so maybe I accidentally borked something. ;) The NetBoot service does work though.

New Contributor II

The fix is pretty simple.

SSH to the NetSUS, using an account with sudo access.
Type the following command:
sudo sed -i 's/browseable.*/browseable = yes/' /etc/samba/conf.d/netboot.conf

The NetBoot share was immediately visible with a simple Command-K connection, or using the link in the browser.

My test NetSUS didn't even require a restart of the smbd service for the change to take effect.

The base code will be updated shortly, and this fix will be incorporated in the next release.