New Distribution Point + AutoPKG Trouble

ktaylor25
New Contributor II

Hello,

I recently moved my DP to a Windows server. Ever since, my AutoPKG recipes fail with an error message: Error mounting url: "smb://org.local;rwaccount:rwpass@servername.org.local:139/OIT-DiskStation/CasperShare": None

The path to the DP is smb://servername/OIT-DiskStation/CasperShare

In Jamf DP settings, the share name is entered as "OIT-DiskStation/CasperShare" (without quotes). Policies all work fine.

I've verified the RW account works. I can manually mount the DP no problem using that account, and as I said policies have no problem executing.

If I change the share name in Jamf DP settings to just "OIT-DiskStation" (without the /CasperShare), AutoPKG works! The recipes run and the package shows up in the correct spot (OIT-DiskStation/CasperShare/Packages). However, if I leave it this way, my policies then fail!

I even tried setting up a fresh clean instance of AutoPKG on a new machine but I get the exact same issues there.

Any ideas for additional troubleshooting steps?

Thanks!

1 ACCEPTED SOLUTION

ktaylor25
New Contributor II

@DaK3ll3r Yes!

It seems that AutoPKG needs the DP to be the root volume. So instead of smb://servername/OIT-DiskStation/CasperShare, I changed it to smb://servername/CasperShare and it now works no problem!

View solution in original post

2 REPLIES 2

DaK3ll3r
New Contributor II

Did you ever get this figured out? I just moved to Windows HTTPS servers and am seeing the same issue, but only for one of my two servers.

ktaylor25
New Contributor II

@DaK3ll3r Yes!

It seems that AutoPKG needs the DP to be the root volume. So instead of smb://servername/OIT-DiskStation/CasperShare, I changed it to smb://servername/CasperShare and it now works no problem!

View solution in original post