Nightly Disconnects - Wired Macs

New Contributor III

I posted this on Apple's community but haven't gotten any responses from anyone, so re-posting here to see if anyone has any suggestions. Also, I spoke with apple and they sent me troubleshooting wifi connectivity, our machines are on wired only, but said it can help. Then she told me that the network switch might need to be reconfig'd to work with mac's? Iv'e never heard that before. Anyone else?

We have a couple dozen or so Mac's that for some reason, disconnect from the network on random nights during the week/weekend.

We use a NAS system called Nasuni which all users connect to and use throughout the day and for some reason a process during the evening disconnects them. I've disabled all power management settings using pmset (sleep=0, hibernatemode=0, disablsleep=1) and made sure power nap is turned off. I've even run caffeinate via terminal and had the user start a render from AfterEffects to one of the network drives, and still got disconnected.

From what we can tell it's not the NAS, it's just recording that the machine was disconnected adn then reconnected. The router/switch isn't going down or anything. The mac's are wide awake, no dark wake events since disabling all pm. We're at our wits end. The windows machines, as far as we can tell, do not get disconnected, or they do but it's a) not recorded in the event logs, and b) they reconnect much more elegantly than the macs in that network drives or 'shortcuts' dragged to the sidebar don't disappear. Further evidence that it's not a clean disconnect is that the hidden folders created by mounted volumes under /Volumes starts numbering up. For example, the user maps a volume called "Dept", so a folder gets created called /Volumes/Dept, then when they come back the next day, they have to reconnect, and then a folder called /Volumes/Dept-1 gets created thus throwing off the links they have to placed art in their artwork.

I'm going to see if we can wireshark one of their lines, to see what's going on, but not sure if that'll help or not.

This is happening on 10.12 and 10.13 iMac's and MacBooks, brand new and older, all on wired, not wireless.

I've also tried combing through their system logs to see if it tells me what causes it but there's nothing in them about a disconnect.

Any ideas? Been struggling with this since October 2017 myself, the users just got used to it and think it's normal (been going on for them for almost 3 years now).


New Contributor III

They also tried telling me our network may not be configured to handle the number of machines (we have like 4 cisco switches (same as on another floor, config'd the same). Is there a way to get to a senior support person or someone who helps with companies and not home users?

Valued Contributor III

The obvious thing to do if you haven't already is move one of the devices to a network location where other machines are known to work. If the problem goes away it's likely the network.
If the problem persists it's almost certainly the Mac itself.

New Contributor III

As we swap out machines we're doing that, but because it's random it takes forever to see if it happens. This place isnt' one to have spare mac's laying around unfortunately. Well until I got here, now we're going to have some so i can do some official testing.

They're all on the same network however on that floor, and the pc's don't have any issues. And the network team stated that nothing is different between the floors, routers, etc. The whole anti-mac attitude makes it quite difficult to get them to dig in deep. We are going to do some wireshark testing soon, so perhaps that will shed some light.

At this point though, there are only a couple users reporting it after the power management settings were changed. And one of those machines is being swapped out soon, so we'll see what happens. He was doing the rendering to the network from AE overnight and got disconnected. I tried running caffeinate on his machine as well, same result. But that was prior to the power management settings. it may just be their machines at this point.

I've also tried creating/modifying the nsmb.conf file with MANY options (one by one, and together) to no avail.

Contributor II

Are these machines static IPs or DHCP? Is it possible that the DHCP is releasing after a set period of time which causes them to grab an IP again (most likely still the same IP) Do you deploy anything like Cisco ISE on your network?

New Contributor III

@ammonsc They're DHCP, I'll see about setting them to static and see if that helps. I didn't even think to go there. I'll keep this post updated.

Another oddity to add, one of the users, when she adds a folder to her sidebar, she has a TON (not a great process, but it's how she works, we're trying to get her to use aliases instead) she would lose them all once disconnected. Now, she only loses ones she's used. So if she drags Folder A over to the sidebar, uses it for a day or two, then it would just disappear while others stay put and are useable.

So that may not be a disconnection issue, might be something else. She's in dire need of a reimage, but won't let anyone near her machine as she doesn't want to have to customize it. So we've told her to expect oddities but her VP keeps pushing to 'fix it'.

New Contributor III

So setting them to static did not help. Had a user last night get disconnected at 7:00CST, and when I look in her opendirectoryd.log file I see this error: ActiveDirectory failed to make a connection to '/ActiveDirectory/<domain>/Global Catalog'

Google isn't much help as it all points to Microsoft/Windows fixes, etc.

I'm going to pull her machine off the domain and put it back on to see if that helps, but not sure what else to do. I also have Centrify's ADCheck utility to see what it gets from her machine (we don't use any third party ad bind apps, etc.).

I did a dsconfigad -show and got the following:

Active Directory Forest = <our domain> Active Directory Domain = <our domain> Computer Account = <valid machine name>$ Advanced Options - User Experience Create mobile account at login = Disabled Require confirmation = Enabled Force home to startup disk = Enabled Mount home as sharepoint = Enabled Use Windows UNC path for home = Enabled Network protocol to be used = smb Default user Shell = /bin/bash Advanced Options - Mappings Mapping UID to attribute = not set Mapping user GID to attribute = not set Mapping group GID to attribute = not set Generate Kerberos authority = Enabled Advanced Options - Administrative Preferred Domain controller = <valid controller> Allowed admin groups = not set Authentication from any domain = Enabled Packet signing = allow Packet encryption = allow Password change interval = 14 Restrict Dynamic DNS updates = not set Namespace mode = domain

I have wireshark available to use on her machine, just not sure if it'll help or not, and it's so random so I could run it for days and then not get anything.

Apple still wants me to do the wifi stuff, even though I've disabled wifi altogether.