No license was found for app "com.jamfsoftware.selfservice".

New Contributor III

A student came to me earlier because she was unable to install an app in Self Service that she needed. Her iPad's Jamf page was said no license found under Management > Failed Commands. I closed out of Self Service, did a hard reset of the iPad, etc. It still gave me the same error so I deleted Self Service and pushed out Update Inventory. That's when I got the error in my subject. Self Service is definitely in her scope, and we have more than enough licenses.

Other things I've done are remove everything from User and Location, remove her from the smart groups we use to assign the app licenses, and deleted her account from within Users with no luck. I even tried to re-enroll her iPad, but it failed with the error "a profile containing an MDM payload must be removable).

The iPad is a 6th gen with iOS 12.1.1 (had 12.1 when she gave it to me so I updated it). We're currently running Jamf Pro 10.7.1.

I did configure a loaner iPad with her account, and everything installed fine on it. So she has something to work on while I try to remedy this. I haven't gone nuclear on her iPad yet. That's the last resort.


Valued Contributor II

I have one thought - launch the App Store and see if it is trying to download as a user licensed app. Cancel it if so and then try Self Service again.

New Contributor III

It just started working properly out of the blue one morning about a week later.