No Remote Management prompt after OS install

New Contributor III

Hi All,

I tired all the steps mentioned below but still the Remote Management fails to appear after doing "n" number of factory resets :

1. Shut down the device

2. Erase the device

3. Unassign from MDM and ABM

4. Restarted the device

5. Assign ABM and MDM profile 

Also tried the following commands in Terminal during restart  :

a. profiles renew -type enrollment

It says profile : command not found

For below 2 commands , it asks for password for user_mbsetpuser

b. sudo profiles renew -type enrollment 

c. sudo profiles -N



Valued Contributor

Have you made sure that the serial number of this system is scoped in the prestage enrollment? The serial number may be there, but it needs to be checked. Also, what happens if you move on and just setup an account on the Mac, and then use "sudo profiles renew -type enrollment" in Terminal?

Contributor III

Whats the error when when you run "sudo profiles renew -type enrollment"?

Do you see the device in  Global Management > Automated Device Enrollment > Devices?

It says profile : command not found

Are you typing this with an "s" at the end of profiles? I tried recreating the issue. When I type the command "sudo profiles renew -type enrollment" I am prompted for my password and then nothing happens since I'm using a Mac that is already enrolled and it is not in ABM. When I type it with the "s" missing from profiles I get the same result you did.

Screen Shot 2022-01-05 at 10.30.40.png

Device is enrolled in Jamf pro and ABM , also tested with profile but it is asking for password mbsetupuser$

Valued Contributor II

Your workflow above sounds like it needs be to reworked.

At present you're wiping/reinstalling, un-assign in ABM, restarting, then assigned again and added to your pre-stage once I assume the machine had already booted to the setup assistant. If you have it connected to an ethernet adapter then the machine has already determined it's not assigned to any mdm service and to proceed with a regular consumer setup.

What you need to do is:

1. If the device is enrolled in Jamf Pro already flush all of it's policy logs if they aren't already.

2. Boot to internet recovery or a flash drive installer of MacOS, wipe the drive and reinstall MacOS.

3. While it's reinstalling assign the device in ABM to your Jamf Pro instance. Once it appears in your pre-stage ensure the serial number is checked and click save. This needs to be done the moment you start the install to give the two time to sync with each other.


Its profiles (not profile).

Device is enrolled in Jamf pro and ABM , also tested with profile but it is asking for password mbsetupuser$


What do you mean by "tested with profile". What are you doing that triggers the request for a password? If a Mac is in Apple Business Manager, and you have a working  prestage enrollment in place, and the Mac is scoped to this prestage enrollment, then it should auto-enroll when it is first booted up after being erased and reinstalled. I am not understanding what your workflow is. To help you, we need to know what steps you are following.

Valued Contributor

Why are you removing it from MDM and/or Apple Business Manager?  Once assigned, there shouldn't be a need to unassigned and then reassign.  This step is not required if you simply want to erase the device and redeploy it to a different user.


I'd go back to Apple Business Manager and verify that the device is assigned to Jamf Pro, and in turn the device is checked in the appropriate PreStage in Jamf Pro.  Once that is done (and you've allowed the 5-10min for everything to sync), erase the device again and run it through Setup Assistant.  It should enroll as you have configured in the PreStage.