NoMAD asking to login twice each time when the user try's to login

New Contributor II


I have had a support ticket with JAMF open for well over a month and we unfortunately have not been successful in fixing this issue, I am wondering if anyone else has had this issue and were able to solve it?

Upon logging in to a device with NoMAD Login installed on it, the user will put their credentials in and press enter to login, it will glitch and the credentials will disappear. The second time they put their credentials in it will log them in. I would prefer only needing one set of credentials to login!

  • I have manipulated my script and even stripped it to barely anything to ensure it wasn't anything I had badly scripted!

  • I have downloaded a new version of NoMAD login just encase the one I downloaded was a bad file.

  • Tried over both Ethernet and WI-FI just encase its taking too long to reach our LDAP / AD

  • Wiped the machine (it is a replicated issue happening on at least 20 desktop machines in our shared labs)

See below the Post Install Script and configuration profile. I have blanked out our AD Domain.



If anyone had any sort of idea or solution I would be so grateful!



New Contributor

I recently discovered this behavior in multiple machines as well. When attempting to login the SAME password would work for both the FV login and proceeding login screen.
Typically if this was a problem with the AD and FV2 password being mismatched, this is NOT the expected behavior.

I did not change anything in our NoMAD or AD deployment. This seems to have started recently.

After testing I discovered that even when using valid and previously working AD Domain Admin Creds, when attempting to bind or re-bind an impacted unit to AD an error would appear related to the account " Not having sufficient permissions to overwrite an exiting entry for computername". Oddly, even after deleting the computer from AD and waiting for replication across all domain controllers, this error persisted. I changed the computer name to something else when attempting to bind and it was able to proceed and bind without error.

After this the login flow worked as it should with just one login screen and the valid and current AD password for the user being used.
I am now getting reports of this happening to MORE users. I will test this to see if this fixes it for them.
Maybe this will for you too.

New Contributor

I still have this issue on multiple machines

Valued Contributor
Valued Contributor

Have you tried using a configuration profile instead using a script to write out the plist via defaults? Maybe try stripping everything down to the bare minimum and just a profile and install the NoMAD-Login package. I don't see any reason it should make a difference, but worth trying.

Also, if you want, go to and sign up for the Mac Admins Slack community and post your issue there. There is a dedicated change to NoMAD login (#nomad-login) that may be able to help. There are several people on that channel that have contributed to the application.