nsurlstoraged Console errors

New Contributor

Hey everyone,

I've noticed on our managed machines we've been receiving the following console errors:

realpath() returned NULL for /var/root/Library/Caches/jamf

The read-connection to the DB=/var/root/Library/Caches/jamf/Cache.db is NOT valid. Unable to determine schema version.

ERROR: unable to determine file-system usage for FS-backed cache at /var/root/Library/Caches/jamf/fsCachedData. Errno=13

It seems to happen on every check-in, and nothing has changed on our JSS since. Any advice or anyone who has received this issue before? Thanks in advance!


Honored Contributor II
Honored Contributor II

Not sure what the cause is but its in my console logs as well.

Contributor II

Are you getting Kernel Panics with these by chance? This error is the last thing before three Kernel Panics in a row. I am using 9.65.



I'm to starting to see run across the board at some of my clients. Has anyone pin pointed what's the cause of this. I'm getting reports of some users having the system kind of stutter on the network and then catch up. Policies are running without an issue and I can manually recon machine with out an issue. So what is this phantom error? Anyone. Thanks.

New Contributor II

We are seeing these errors as well and after initial installs (Casper Imaging) the Apple System Update and install of Xcode takes several hours on each MacBook. I am wondering if this error is related to the long system update times.

New Contributor

Also seeing these same console logs. JSS 9.63

Unsure as the root cause, we do not use Casper Imaging.

New Contributor II

I'm also seeing this error. JSS 9.63 here as well. Has anyone discovered the cause?

New Contributor II

Just wanted to say that our issues of Apple System Update and install of Xcode taking several hours on each MacBook was due to Bit9.

Contributor II

I am seeing this now, and the error appears to coincide with a failed mounting of our SMB share. Was anyone else seeing associated symptoms with the error in the logs?

New Contributor II

+1 seeing this in my environment too.

New Contributor

Also seeing this on a number of machines while trying to initialise connection to corporate wifi.

New Contributor

Has anyone figured this one out? We're seeing it running 9.73… and using 10.10.5 MacBooks.


New Contributor

Seeing it here as well when trying to initialize to corporate wifi. Running 10.10.4 and wireless profiles pushed out via Casper (9.63). I understand the latest Casper update addresses weirdness with wireless profile creation, so we're waiting on our engineer to update JSS.

Honored Contributor

Still no luck on this one? I'm suddenly getting this on a couple Macs running 10.10.5 on JSS 9.81 trying to install ANYTHING via Self Service over Ethernet and WiFi. Every policy fails with the same error.
I've done:

jamf removeMdmProfile
jamf mdm
jamf manage

and it didn't fix the problem. It's especially scary that it happened to 2 separate Macs around the same time.

Contributor II

So Almost a year since this thread started...

Still no one with a solution?

We are seeing this error as well.
Scripts (or at least the FireFox Update script) are not running......

So if anyone has a solution please share.....

edit: so as it turns out.. My problem was solved by re-adding the script to casper.. For some reason the script was damaged in the database. (did a remove and added new)

Honored Contributor

For me, it seemed to clear up on its own. Those are the scariest problems of all. They come and go as they please without explanation.

Contributor II

Seeing this error

11/16/16 2:24:08.513 PM nsurlstoraged[45981]: The read-connection to the DB=/var/root/Library/Caches/jamf/Cache.db is NOT valid. Unable to determine schema version. 11/16/16 2:24:08.513 PM nsurlstoraged[45981]: realpath() returned NULL for /var/root/Library/Caches/jamf

On many test machines (OS 10.10.5 ---JSS v 9.96)
One test user reports wireless network drops and it took a Turn Wi-Fi off and On again to solve his network issue.


I've built a brand new 9.98 server and am getting this issue on my test macs with the exact same issues listed above!