Office 2016 default Save dialog mode

AVmcclint
Valued Contributor III

We have the volume license version of Office 2016 and I've come to really hate the default Save dialog box that is just a few blank columns with no real indication of what the user is looking at and it is very confusing for them to know what to do next. 86214d2257024f7b9d2561a0fb62a342

Yes, there is the "On My Mac" button there in the lower left but if the user needs to save a file to our file server, that's not "On My Mac". This is a horrible design by MS and I will register my complaint with them accordingly.

To avoid the inevitable questions that this will generate, is there a "default" command that I can roll into a Policy and set the save dialog box to "On My Mac" mode instead of "Online Locations" mode?

49 REPLIES 49

jlbrown
New Contributor

L, I didn't deploy it with Jamf - just entered the defaults command in Terminal on my machine.

So it works with you for Open dialog in Excel?

Save dialog is OK, but I get no change in Open dialog in Excel.

Both Open and Save work in Word.

Nix4Life
Valued Contributor

@jlbrown My mistake, I was confused as I was on my home machine. I just checked and you are correct. You get the following when you choose Open. Once you choose "on my Mac", you are taken to the Documents folder. Have you jumped on slack?
5164252efa814315aa15b1675f38c80f

Nix4Life
Valued Contributor

@jlbrown not sure if you saw the update, but the defaults command has changed as of 15.33. As usual, Rich has updated his script and profile. it can found here.
I confirmed it does work for Excel now. It must be run with root privileges

sudo /usr/bin/defaults write /Library/Preferences/com.microsoft.office DefaultsToLocalOpenSave -bool true

jlbrown
New Contributor

Thanks for the post @LSinNY - I did miss Rich's update.

Ran the defaults command but didn't work.

My /Library/Preferences/com.microsoft.office file is empty.

Office version 15.34 (170426)

Nix4Life
Valued Contributor

@jlbrown my Bad. I posted on an iphone. the command should be:

/usr/bin/defaults write /Library/Preferences/com.microsoft.office.plist  DefaultsToLocalOpenSave -bool true

checked:
LarrysiMac$ /usr/bin/defaults read /Library/Preferences/com.microsoft.office.plist
{ DefaultsToLocalOpenSave = 1;
}

jlbrown
New Contributor

Thanks @LSinNY - that works.

Open and Save in Word, but still only Save in Excel.

Thanks again (and thanks Rich!)

agerson
New Contributor III

Tested a variety of these solutions on Mac 10.12.4 and Office 15.29 and did not get a single one to work. I must be doing something wrong but I don't know what. I was logged in as a test local user and making these changes, as root when needed, but specifying the test users home paths when needed. This did work: [https://www.jamf.com/jamf-nation/discussions/20571/office-2016-for-mac-disable-cloud-services-onedrive-sharepoint](link URL)

gachowski
Valued Contributor II

Any updates to this, I just gave it a short try and looked like it's back to the "MicrosoftRegistrationDB.reg"?

C

cddwyer
Contributor

@genazzano Jamf runs scripts as root so if you refer to a home directory it will use root's. To run a command as another user use:

#!/bin/bash

#Figures out the logged in user and puts username into variable
USER=$(ls -l /dev/console | awk '{print $3}')

#Use su (switch user) command then reference the variable containing the logged on user's username then pass the command you need in single quotes

su $USER -c 'command to run as logged on user goes here'

exit 0

Good luck

psalgado
New Contributor

This profile shows the Finder as the first option to save Office documents

Guarda documentos de Office localmente por defecto .mobileconfig