Office 2016 Kerberos authentication required

Mark_Ballestero
New Contributor

When opening any Office 2016 product. I get a popup saying Kerberos authentication required. 8c279703fbc945faa99cb1c5ef66386c
Clicking renew gives the screen below. Anyone run into this issue? I have omextemplates.content.office.net in proxy bypass as well. Any help would be appreciated. Thanks!
4747e3f0fed24b06b542316204810be7

11 REPLIES 11

Swift
New Contributor II

May or may not help... but I have this in my /etc/hosts file to prevent similar authentication pop-ups.

127.0.0.1   prod-w.nexus.live.com.akadns.net odc.officeapps.live.com omextemplates.content.office.net officeclient.microsoft.com store.office.com nexusrules.officeapps.live.com nexus.officeapps.live.com

Mark_Ballestero
New Contributor

@Swift Thank you for the suggestion but it didn't appear to solve my problem.

talkingmoose
Honored Contributor II
Honored Contributor II

Kerberos is probably enabled on your proxy server. It's not something Office for Mac itself uses. The expiration in your screenshot compared with the time of your post here suggests you're receiving the authentication prompt although you have a valid Kerberos ticket. That sounds like a proxy issue to me.

The reason you're being prompted for credentials is your proxy is receiving traffic from various parts of Office that are trying to access Microsoft servers. For a detailed list of servers that Office uses, see this document put together by Paul Bowden with Microsoft: http://macadmins.software/docs/Network_Traffic.pdf.

Adding the server address to the proxy bypass list might work to quash the message, but I think you'd have a better user experience if you worked with your network administrator to address all the addresses in the document above. Of course, Microsoft will suggest you allow unfettered access to these addresses from any client on your network. Your network administrator may have a preferred method for dealing with them.

Mark_Ballestero
New Contributor

@talkingmoose Sorry for the delay on this response. Thank you for the suggestion as well as the link to the documentation. We will work with our network team to see if this solves our issue. I'll let you know if it works.

Mark_Ballestero
New Contributor

@talkingmoose would you happen to know if these links are applicable to the Windows side as well? My network admin was wondering if this will open for the Windows side of the environment.

Thanks

talkingmoose
Honored Contributor II
Honored Contributor II

@Mark.Ballesteros, to my knowledge, Microsoft has no Mac-specific online services. Windows, however, does have some that are specific such as Visio.

I would consider the support document referenced in the PDF to be authoritative for all versions of Office and the Network PDF on macadmins.software to be a subset that's specific to Mac.

Alexi
New Contributor

I had the same problem. For me it was sufficient to put "http://local" in the field "Bypass proxy settings..." on the Network > Proxies tab:
https://support.microsoft.com/en-us/help/2019105/authentication-requests-when-you-open-office-documents

eb_pc
New Contributor

I ran into this exact issue and found this to be the solution:

In Terminal run "kinit youraccountname"(use FQDN in CAPS for domain account). The kinit command is to refresh Kerberos certificate from the Domain Controller. Hope this helps others, thanks.

k3vmo
Contributor

Problem is - in my situation - each system has a valid ticket - I'm going the route of investigating the proxy server. After talking with Microsoft Support -they recommended the same

rqomsiya
Contributor III

I've been running into this issue. The only way around our proxy was to create a RDNS rule to bypass the proxy for those specific MS URLs. So far its been working well.

We use Bluecoat and ran into a few issues during the RDNS setup. Let me know if you need more details/insight.

Vernaf
New Contributor

@ rqomsiya I am running into the same issue using Bluecoat. Could you elaborate on what is an RDNS setup?