Paralles 8 deployment

Fjord
New Contributor

I had a simular issue with VMware 5.0.2.
I found the issue after reading again the deployment guide.

Unfortunately the deployment guide for Parallels 6 seems to be not working correctly on Version 8.0.1.xx.
Has somebody already deployed this?

Thanks a lot.

8 REPLIES 8

donmontalvo
Esteemed Contributor II

Are you using the Parallels wrapper package? All you need to do is drop in the latest Parallels 8 DMG, and populate the text file with the volume key, and drop your VM in there while you're at it (if you want to deploy the whole enchalada). We've been deploying this for months with no issues...unless you deploy a VM with tools that are older than the Parallels version, then the user gets prompted to update tools on first VM launch.

http://www.parallels.com/fileadmin/parallels/documents/desktop-virtualization/Enterprise/Parallels_D...

http://download.parallels.com/desktop/tools/pd-autodeploy.zip

--
https://donmontalvo.com

Fjord
New Contributor

Thanks. So serial number is needed to successfully install it?

carmelolopez
Contributor

Hi Don,
I had no issues until I started deploying it on 10.8.2 and SSD.
The package shows installed before deploying the VM image (around 15g). Have you seen also this issue?
Thanks
Carmelo

Fjord
New Contributor

Don, installation is working now fine.
I figured out that Self Service is showing "Installation failed".
This seems to be in relation to the empty license file.

@Carmelo: I have no problems with 10.8.2 and SSDs. Running like charm now.

myronjoffe
Contributor III

Im using the parallels wrapper to deploy but it fails when i try deploy using Casper Remote either caching or installing on the fly.

The logs report the following: Installation failed. The installer reported: installer: Package name is Parallels Autodeploy Package ; installer: The upgrade failed (The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.)

By fail i mean I get the above messages but I am still able to launch parallels.app but get prompted to activate the license.

If i install by dbl clicking the package on the desktop it installs fine and is licenses as expected. Im spending far too much time on this. Anyone have any ideas?

jhbush
Valued Contributor II

You may want to try caching it first then run the command below to make the serialization happens. You may also want to check that the proper ports are open for the activation agent to phone home.

jamf install -package Parallels8018354.pkg -path /Library/Application Support/JAMF/Waiting Room/ -target / && prlsrvctl install-license --key yourkeyhere

pickerin
Contributor II

I just started deploying Parallels 8 today and was successful with two users. Have you tried it via Self Service and verified that it works?

I'm guessing the issue is that when deployed via Casper Remote, it's running as the admin user, not the local user? All of mine have been via Self Service and it's worked well.

I believe if you're using the pd-autodeploy wrapper, you have to have a serial number in the License.txt file, otherwise the install will error out. I've been making custom packages for each of my license keys (not efficient, but it works).

myronjoffe
Contributor III

Thanks @pickerin worked a treat in SS.