Pharos Notify & Popup issue on Monterey 12.5.1

New Contributor II

Pharos Notify & Popup issue on Monterey 12.5.1

This software has worked darn near flawlessly until now(hasn't been updated since 2018?).  Even though the Firewall is set correctly, neither of the Pharos components(Popup & Notify) can communicate with the server for whatever reason.

Screenshot attached(Well, I don't have 'permission' to add graphics?). :-p 





You ever figure this out?  I am troubleshooting installing Pharos on Ventura.  I found that if I install it as local admin it is fine.  If I install it using jamf, the launchdaemon is not present. If I toggle the Pharos login item in system settings, the launchdaemons starts fine.

Trying to figure out how to automate that. I gave the same info to Pharos, and they have not been able to help.

New Contributor

Did anyone ever figure out a solution to this? I had the same result as dhausman. Package and printers deploy just fine but popup only works if the login item is toggled off and back on. Pharos does not seem to care about testing their software with different deployment configs/newer OSes.



I did get it working, Pharos was terrible to work with. It took them from October until the end of march to "fix" their software. It is still kind of broken in ways because I found through testing the order of how stuff was installed mattered.Here is how I did it. There is an updated popup.pkg that you will need from the pharos site.

I have a package that puts these files into /Users/Shared/




Then it installs Popup.pkg via the policy. Note the Xerox drivers need to be installed later (after popup.pkg).


I have a post install script that runs from Jamf scripts via the policy not from the package. It did not install correctly if I ran the script as a post install built into the pkg.


The trick to get it to work was do this first:
# Remove previous Pharos install

lpadmin -x (insert your named destination)


# Create Popup queue

lpadmin -p EmployeeFollowMePrinting -D "Employee Follow Me Printing" -v popup://(your server locaiton) -E -P /Users/Shared/Xerox8045.ppd -o printer-is-shared=false -o XROutputColor=PintAsColor