Policy refusing to run on check in

New Contributor

I have a policy that is scoped to a single machine checking if a folder exists on the machine, if it doesn't exist it shows an error telling them to see the ICT department.

If I run sudo jamf policy the policy runs, executes the scrupt, and does what it is meant to. However it is set to run on recurring check in. The check in is set for 1 hour in JAMF settings on the server. The dashboard says the device is checking in on the hour as scheduled. But the policy with the script is not working on the schedule.

Thoughts on what is happening? We have other scripts that run, such as ntp check in, policy for apps and other things. This one just wont run.

Any help would be greatly appreciated


Contributor III

Is it stuck on "Pending"?
What happens if you run it via a custom trigger?

Legendary Contributor III

What are you seeing in the policy log? Is it still pending even after the check in time has long elapsed? If so, go back and check your settings in the policy, like make sure the execution frequency isn’t set to something that might prevent it from running.

If the log shows it ran but the message didn’t pop up, that could be a security issue, like that the OS is preventing the message from coming up on screen perhaps.

Valued Contributor III

The only thing I can think of is to validate your scoping and make sure there are no limitations on when it can run. Whenever I run across this sort of thing I find I had a client-side limitation preventing it from running on weekends or something like that. In your case it might be a user-based scope, based on what you stated about it working when you run it manually from Terminal vs the recurring trigger.