Pre-Stage and Big Sur

retroroscoe
Contributor

Hi, has anyone else attempted to do a pre-stage enrollment with a macOS Big Sur client? Currently, I'm getting it to enroll but it shows up as unmanaged.

21 REPLIES 21

mikeh
Contributor II

Failing here as well. I've heard that Jamf 10.21 is failing to download the jamf binary client during enrollment due to MDM client changes in Big Sur. The client download is rumored to be fixed in Jamf 10.22.

Luckily, upgrading an existing machine maintains the jamf binary and the machine remains managed.

sdagley
Honored Contributor II

It's JSS ~~10.23~~10.24 that should have support for enrolling Big Sur systems (10.22.1 is already out and Jamf isn't likely to do a .2 release to support a macOS Beta)

MatG
Contributor III

10.23 work or now is it 10.24?

sdagley
Honored Contributor II

@MatG Looks like it didn't make the cut for 10.23, so you'll need the 10.24 beta if you want to test enrolling a Mac running a Big Sur beta

gforsyth
New Contributor III

Same Here. Prestage Enrollment is hosed. Thankfully upgraded machines still have the binary. Anyone seen any issues on upgraded Big Sur Macs?

janselmi3953
New Contributor III

I'm on 10.25.1 and it's working normally. I believe Big Sur was officially supported starting in version 10.25.

The problem I'm noticing is that the test client I have is being added as 10.16.0 instead of 11.0.1. Not sure if JAMF will update this so it will reflect the actual version name, but I rely heavily on smart groups for config profiles and policies related to 10.15 machines, 10.14 machines, etc.

sdamiano
Contributor

Intel macs will be listed as 10.16, ARM macs will be version 11. This is intentional and has to do with how versioning works in macOS now. https://eclecticlight.co/2020/08/13/macos-version-numbering-isnt-so-simple/ https://www.jamf.com/jamf-nation/discussions/37295/big-sur-version-number

mike_paul
Contributor III

Hello, thanks for the post and the discussion around this. Sorry for the confusion.

Apple reports Big Sur in two different ways depending on if the binary checking the OS build was built on previous versions of Xcode or the newly released version of Xcode 12.

Starting with Jamf Pro 10.25.2, released today, the Jamf Pro management framework has been updated with Xcode 12 so it will now report Big Sur as macOS 11.

Rebuilding our Jamf Management Framework on Xcode 12 for Jamf Pro 10.25.2 will allow Automated Device Enrollment (AKA DEP) to be successful on hardware that ships without Rosetta. Of course, the previous supported features of User Initiated Enrollment (UIE) and management of Big Sur already exists in 10.25.1.

Please let us know if you have any questions.

Thanks!
Mike

retroroscoe
Contributor

Hi, to clarify, is Pre-Stage Enrollment working with Big Sur and 10.25.2? I have just reimaged a machine and it appears to be not working.

ThijsX
Valued Contributor

@retroroscoe Since yesterday before 10.25.2 upgrade some of devices began reporting as OS Version 11.X, and a test Mac with Big Sur reporting as 11.X now fails to enroll, after Setup Assistant and retrieving profiles the account payload is not being respected and when on Desktop the Jamf binary is not being installed and only profiles are in place.

Cloud instance upgraded to 10.25.2 and same behaviour, going to test some more devices.

davidi4
New Contributor III

Has anyone experienced an issue with PreStage enrollment packages? The management history for Big Sur machines shows the packages “installed” but the bits never get on the machine. Nothing in the install.log either. Cloud JSS 10.25.2.

Jamf support has not been helpful in troubleshooting this.

hunter_gardner
New Contributor II

@davidi4 we are experiencing the same issue. Even tried to use Jamf Recon to enroll the machine but get an error that says it can't install the Jamf binary. Actively searching for a fix.

Nick1403
New Contributor III

Hello, does anyone already have a solution how to get the Pre Stage Enrollment to work again on a M1 Mac?
Cloud instance upgraded to 10.26.0. The pre-stage registration is displayed and the profiles are installed, but the Jamf binary is not installed.

EdLuo
Contributor

We were upgraded to 10.26.0 over this past weekend and I was able to re-enroll my MBA with M1 chip without issue. Prior to that, we were on 10.25.1 and experienced the exact same issue mentioned, "The pre-stage registration is displayed and the profiles are installed, but the Jamf binary is not installed". If you are already on Jamf 10.26.0, try the following command to wipe and reinstall Big Sur so Prestage enrollment runs again.

sudo softwareupdate --fetch-full-installer
'/Applications/Install macOS Big Sur.app/Contents/Resources/startosinstall' --eraseinstall --agreetolicense --forcequitapps --newvolumename 'Macintosh HD'

abutterman
New Contributor III

I noticed an issue on at least one computer yesterday (MacBook Pro with Touch Bar, Intel), where I would boot to recovery, wipe the drive, reinstall Big Sur and during the setup wizard it would reboot again after the first one or 2 settings to complete installation. It would then come back up and be at the Remote Management screen where it looks like it's working ok. However, once I create my account and log in, there is no Jamf Binary installed. This is on 10.26 Jamf Pro Cloud. I am able to use the quick add package from there to install the binary but if this becomes more widespread, this is less than ideal.

abutterman
New Contributor III

Edit: that same computer where it happened at least 3 times in a row yesterday worked successfully just now. Not sure what's going on with that.

mcantwell
New Contributor III

I had them upgrade our instance to 10.26.1 but I still cannot PreStage enroll a Big Sur machine. I get the Remote Management screen and it creates the admin account but does not install the jamf binary (note this is an Intel machine). What am I doing wrong?

JVernon
New Contributor

Is anyone else still getting this? We're on 10.27.0 but still having this issue after multiple re-installs on multiple machines.

dtekum
New Contributor III

Has anyone found a solution for this? I have been unable to prestage computers ( Big Sur and Catalina, not M1) it does not install the jamf binary. the jamf support is very unreliable!!!

pmartin
New Contributor II

I am seeing this too.

jp4050
New Contributor II

I'm still getting this. Only workaround I have done is to use User-Initiated enroll via URL after the DEP Enrollment to get the quick package to install the binary. This is not ideal and lightyears from "Zero Touch" deployment.

Hope to hear something soon.