PreStage Enrollment Not working

New Contributor III

I seem to be having a problem with PreStage enrollment. I had 2 computers purchased recently and neither went through the process at all.
The computers macbooks were purchased the same way as always.

If I Open Apple business Manager and goto Assignment History, both laptops with the correct serial numbers are listed there.

When I log into Jamf and goto PreStage Enrollments, and then goto scope, the devices are listed there.

However, when the computers were first turned on by the remote employees, etc. Jamf did not kick in and I had to send the employees email invitations.

Any ideas on what to check or troubleshoot? I don't think anything has changed.


New Contributor

did you ever figure this out? I just experienced the same thing - not sure what caused it?

New Contributor

@jkahgee Just got back from vacation. Set up Pre-stage enrollment, confirmed by serial that the Macs I need are in the pre-stage scope. Last sync was recent too, but my new Macs out of the box aren't picking up the pre-stage.

New Contributor

Same issue - MACS not enrolling. They are listed with correct serial numbers in Apple Business Manager.

New Contributor

I am having the same experience with some MacBooks (Air and Pro), yet the iMacs that were purchased for our academic labs are working properly. I know that Jamf has a case open with Apple on this issue. It seems to be an OS problem, but I find it funny that it seems to be hardware dependent.

The person at Apple who I spoke with about this problem told me to boot into repair mode and upgrade the OS and try again (which never worked for me) or to reformat/reinstall the OS until it worked and allowing the machine to cool down between attempts if it was hot. This process worked sometimes, but not reliably.

In the end, for a number of the computers, I just sent an enrollment invitation and enrolled them the systems that way. Being on a tight schedule doesn't allow me to play around with reformatting/reinstalling the OS repeatedly.

Contributor III

@chuck.johnson Could this be something to do with connection type? Are the iMacs using Ethernet but the MacBooks are all using Wi-Fi? Have you tried plugging in an Ethernet dongle to the MacBooks and see if they pick up the Device Enrollment process.

New Contributor

@snowfox I connect the MacBooks up to the Ethernet using an Apple Thunderbolt 3 to Thunderbolt2 Thunderbolt2 to Ethernet adapter. I've also used USB C to USB USB Ethernet adapter. Since Apple doesn't initially allow for connection to a WPA2 Enterprise connection out of the box for configuration...

Apple and Jamf has had multiple users report the issue to them. I trust that Apple will figure it out in a future update.

New Contributor

We were getting the error "Enrolling with management server failed. The MDM server for your organization returned an unexpected status (500).

Zac from support solved our issue! There was no push certificate installed. A notification is supposed to pop up regarding this, so they're going to fix that on their end.

New Contributor II

This is what worked for us! We had about 90 Macs that would not take the DEP profiles, even with multipe wipes.

This website also helped!

New Contributor

@drodenbaugh the links aren't working...

New Contributor II

Any update on this? We're experiencing this issue as well and its such a problem and so sporadic that we've abandoned zero-touch for an in-office manual setup approach. The computers don't hang on any activation record, they just miss the Remote Management screen entirely. @drodenbaugh this solution doesn't solve the issue given that it doesn't allow for an actual zero-touch approach. Really hoping Apple can sort out whatever restrictions they have with home WiFi access as it seems thats where the hang-up is is Apple not allowing the computer to download the pre-stage.

New Contributor III

Tonight, I was getting a "Sync failed: Communication error. Awaiting next sync". I needed to accept new conditions in After that, I downloaded a new DEP token for Jamf Pro. No love. This has been an issue in the past and has solved this issue. Uploading the new token resulted in a "Problem contacting Apple services" in Jamf Pro.

I guess that'll teach me not to work on Saturday night.

New Contributor III

DEP Prestage is working now after the new server token was accepted. Communication with Apple servers seems to be back. Make sure to accept new conditions from Apple at

New Contributor III

I have read in some forums that they recommend reformatting the Mac in these cases, but I found a much faster trick than having to reinstall macOS.

This will only work with a Mac with Apple silicon or with the Apple T2 Security Chip:

  1. Be sure your Mac is connected to the Internet
  2. Complete the initial configuration by creating an 'administrator' account (I know, it is counter-intuitive...)
  3. Once the process is complete, go to: System Preferences > System Preferences menu > Erase All Content and Settings...
  4. Proceed with the full reset
  5. On restart, the PreStage registration process should start as expected

Hoping this will work for you!


Thanks for your time with Jamf Support today! Gonzalo here with a quick email to recap what we discussed in our call today. To recap, we had issues with Computers enrolling but now also seeing that managed Computers are unable to use Self Service and your Jamf Pro server performance is also degrading.During our call, we also ran a mass action command to cancel all pending/failed commands within your instance and so let us know if we saw performance get better after completing this. I also went ahead and submitted a ticket with our Cloud team to run some queries on your server that will help dictate what is causing the performance issues and will get back to you with some next steps soon. If you have any other concerns or questions related to this case, please reply to this email or give us a call we would be happy to assist you!

Mass commands are freezing and timming out.

i will post their resolution here when we are done.