PreStage Enrollment Packages silently fail with Fileshare Distribution Point

New Contributor


I would like to install jamf Connect as an preStage Enrollment Package. So far this has worked with an Cloud Distribution Point (S3), so the Packages should be fine.

For compliance reasons we would like to use a File Share Distribution point, which is also our default way of distributing Packages.

So I set one up without HTTP-Auth specifically for Enrollment Packages. The server is running HTTPS with a certificate from letsencrypt. I added the root-Certficate under Certificates in the PreStage-Enrollment.

To upload packages with jamf Admin I had to set it temporarily as default distribution point. I also verified if I can download Packages with a Browser and it worked.

But when the Mac executes the preStage Enrollment the packages are not installed on the Mac.

In the overview of the computer in Jamf Pro are no signs of failure nor could I find anything useful in the MDM-Debug-Logs ( - Debug-Logging).

If someone could help out, it would be very much appreciated.

Thank you!