Problem Contacting Apple Services DEP

New Contributor III

I am trying to set up DEP on our JSS and when ever I get to the point where I have to upload the server token file, I get the error "Problem contacting Apple services"

I've redownloaded the private key, deleted and recreated the Management server on Apple's side and tried again but always this error. Anyone got any idea why?


New Contributor III

With the help of JAMF support we just figured out the issue. The token was being denied by Apple due to the time on our server not being correct. We run our JSS on ubuntu so I had to set a NTP server, and force it to update the time. After this the token uploaded as it should.

Without JAMF support on this one I would have been at this for who knows how long.

View solution in original post


New Contributor II

@Daikonran The time setting saved me. 2021 and still useful. Thanks :-)

New Contributor III

I run into the "Problem contacting Apple services" error every year and then forget the solution by the next year 😅. Adding the solution for my future self and anyone else with the same issue.

The token must be downloaded from Apple Business using the same account that you've used for previous renewals. If downloaded from a different Apple Business account, you will get this error when uploading the token to Jamf.

Hope this is helpful to someone!

New Contributor

I too got the same error message. Today is the last date for us to renew the Automated Device Enrollment Server Tokens. It assumed that the time may be expired, however expiration date only mentioned on the Console.