"Missing" package in Casper Admin

Contributor III

I'm trying to add a package to Casper Admin - it's an uninstaller for Adobe CS6 - but no matter what I do, it always seems to end up in red as "Missing" in Casper Admin.

When I add it, it seems to upload OK, and shows up as "Pending", but when I then close and reopen Casper Admin it shows in red as "Missing".

I've tried:
- Rebooting our JDS server
- Rebooting our JSS server
- Renaming the package file so it doesn't have any spaces in

None of these things work and I really don't want to have to go round with a USB stick to all our Macs (we're moving from CS6 to CC this summer).

Can anyone suggest anything? We're on Casper Suite 9.92.

Dan Jackson (Lead ITServices Technician).
Long Road Sixth Form College


Honored Contributor II
Honored Contributor II

@DanJ_LRSFC how long are you leaving Casper Admin open before closing it? If you close Casper Admin too quickly when using a JDS, the files sometimes do not get over to the JDS and that will cause the problem you're seeing.

With a JDS, Casper Admin copies things to the databse first, and then over to the JDS. If Casper Admin is closed before the files are flushed out of the database, the files do not show up on the JDS.

You can use some mySQL commands to see if the files are still in the database. If you refer to the following JAMF Nation discussion, the instructions are in there:

Path of a package JDS

Try leaving Casper Admin open for 5 to 10 minutes and then check to see if the file is there. You can also open the JDS share point and watch for the file to show up there before closing CA.

Contributor III

@DanJ_LRSFC I had this occur yesterday with an OS installer, you can monitor if the JDS has fully synced or not in
Management Settings > JDS > then change the view to icons rather than list, if the file hasn't fully synced it will show as waiting.

I was advided by support to run sudo jamfds policy on the server which did the trick, i think in my case the sync had gotten stuck as it was 8GB and i'd waited over a day, the second i ran the command it no longer showed as waiting on the JDS.

New Contributor III

Are you seeing that the full package actually gets added onto the JDS in the /JDS/shares/Caspershare/ location?

If it's a larger package, you could definitely be seeing some oddities possibly dealing with the timing of the different actions used with Casper Admin, JDS, /tmp/ folders and the other pieces involved. Or the more common cause is that the file transfer is getting caught in the database (see the link that was included in a previous comment for inspection and resolution if that's the case).

If it's not getting properly added, you can also just manually add the package to your JDS share by mounting and dropping the package into the /JDS/shares/Caspershare/ location and once the package is in there, run a "jamfds policy" command on the JDS server to update the inventory in the database. This circumvents the multi-step file transfer utilized with additions via Casper Admin. Re-launch Casper Admin, and see if you the issue persists. Of note, if you have multiple JDS' be sure that your do this on the parent JDS.

Esteemed Contributor II

We see this if/when someone makes a change to an item via the JSS web GUI.

Renaming, deleting, etc., in JSS via web GUI, and Casper Admin gets confused.

If an item is deleted directly off the DP, not through Casper Admin, that can cause red entires too.


Valued Contributor III
Valued Contributor III

The times I've seen a "missing" package in Casper Admin is when a package has been uploaded through Admin but hasn't synced from the database to the JDS. You can manually trigger the JDS sync with {{sudo jamfds policy}} (if I remember correctly). Usually, the sync happens at 5-minute intervals. Sometimes a giant package takes a long time to sync (like Office installers or OS installers) so it may show as "missing" for a while.

Esteemed Contributor II

(wrong thread, removed)