"QuickAdd can't be installed on this disk. A newer version of this software already exists on this disk"

New Contributor

I get this error when I try to install my QuickAdd package locally. This is after a recon from the JSS failed previously. How can I manually fix this from the terminal or what files do I have to remove to do a clean install?


Legendary Contributor III

Huh, that's odd. I've never seen such an error before, ever. Typically the QuickAdd pkg doesn't care what was there before. It usually just overwrites any existing files with the ones in the package in my experience.

What I'd try to do is in Terminal run:

sudo jamf removeFramework

If the jamf binary exists already as the QuickAdd is hinting at, it should attempt to completely remove itself and any other Casper Suite related apps, plists and folders. Then try running your QuickAdd.pkg again.

Good luck and let us know how it goes.

New Contributor

Thanks for the response. I'll give that a try.

New Contributor

After running this command I get the same message above. And when I run the "sudo jamf enroll" command it gives me the following error: There was an error. Error enrolling computer: Unable to create a device certificate. Valid credentials are required.

Contributor III

What do you get from running```
jamf -version

Valued Contributor

You might also try to run ```
sudo jamf enroll -prompt
This will ask you for credentials for an administrator account on the machine (this is what will be used as the management account) and an account within the JSS that has permission to enroll.

Contributor III

Any solutions?

Contributor II

Does this machine by any chance have the Adobe CS6 Suite already installed ?

– If it does, there's your culprit.

sudo jamf recon -verbose would show you where it's failing.

It seems that some (several) adobe CS6 applications - such as "Adobe SpeedGrade CS6"
- have internal symlinks, that send recon around and around and around in circles...
- furthermore those particular symlinks appear to be unnecessary.

I have not yet implemented nor tested a solution to this as yet.
But the solution would involve deleting those symlinks.

You could try this on one machine manually to see if it really does resolve the problem.
The symlink (To Adobe SpeedGrade CS6) for instance is buried close to the binary.
(You need to look several layers down inside the .app package)

It does not seem to be created unless you have used the AAMEEE 3.0 or 3.1 installer tool.
ie A Manual install of CS6 lacks this unnecessary symlink.

-- So it seems to be a bug resulting from using those AAMEEE tools.
The problem is Adobe's problem rather then JAMF's - but it causes problems with Casper recon. / Casper QuickAdd.

I am going to be investigating this further shortly - in the next day or so.
– and will try to script a solution to resolve the issue for my own institution.

I also notice that those machines with CS6 from AAMEE 3.0 / 3.1,
-- when their machine record is viewed in Casper admin,
Several of the CS6 applications, then seem to have multiple entries in Casper.
- I think this is caused by this symlink bug. (But haven't yet proved that).

Valued Contributor

I am having this same issue with a mac that does not have CS6 on it. It does have 5.5 though...

New Contributor II

I just ran into this issue with a system that has Creative Cloud installed. Was there a workaround discovered for this?

I'm now finding this on multiple other systems without any Adobe software installed.

New Contributor II

I was able to fix this issue by changing ownership of the QuickAdd package to 777. Every system worked after this.

chmod -R 777 Quickadd.pkg


Actually I had the same thing happen. I fixed it by removing the Casper Server file created inside the receipts folder of the Library. For some reason it didn't want to swap that out.