"The MDM request is invalid" error when pushing iOS apps.

New Contributor II


I'm trying my first go with pushing apps to iOS managed devices that are enrolled in ABM.   The device shows up fine there, and I see the device managed properly in Jamf.   

I'm trying to automatically install Jamf Self Service app to all mobile devices so users can install apps themselves after I make them available, and I followed the instructions here:


When I check the device install status, I'm seeing  the failed install with "The MDM request is invalid". It provides me no other details.  

Feels like I"m missing a step or something.  Can anyone point me in the right directly?


Honored Contributor

You may want to open a JAMF Success ticket especially if its most or all devices. These MDM errors can be very annoying to troubleshoot. Just for the sake of science, have you tried "manually" installing SelfService? 

New Contributor II

Sounds good, I'll try opening a ticket.   The account is a managed Apple ID so I can't download anything manually from the store.  

Honored Contributor

It still comes from the appstore, you just prompt the user to install. The appleID thing may still pose a problem. The bottom half of the instructions on Jamf Self Service for iOS - Jamf Pro Administrator's Guide | Jamf cover "manually" installing Self Service. I quoted "manual" as this is still not really manual. Honestly, it probably uses the same MDM commands that are giving you issues.

Valued Contributor II

Hunting for some further detail. Were you following the automatic or manual install procedure? 

The automatic install procedure assumes you have an "consumer" Apple ID already signed into the device. Managed Apple IDs don't fall into that category as they don't allow the use of e-commerce services such as the App Store, Music, etc. 

If the devices are managed and in ABM then you should get licenses for Self Service from the App Store within ABM as well. You then scope the now synced Self Service app in Jamf Pro and apply the managed app configuration noted in the support article you have. 

Have you setup VPP in your Jamf Pro instance?

Hi mainelysteve,

I have tried both methods to see if this was an issue (Automatic and Manual) and I get the same error either way that shows up in Management pane of the device.  

I did not use VPP.       Full disclosure; I'm very new to Jamf and have not tried deploying apps before, so I've been following the documenation instructions to test this out with one brand new iPad we just purchased this week.  We purchased this through Apple and have devices purchased from there automatically enrolled into our Apple Business Manager.   

We setup a brand new managed Apple ID in ABM to use with this iPad, (as the setup in the iPad indicated we were required to sign in with a managed apple ID since it was in ABM).   

We have sucessfully signed into it with this new Apple ID, and things seem to be going smoothly from there; I can see the device in Jamf as enrolled, managed, etc.   

We want to have the user of this device be able to install an application from the store, but since that's not possible with Managed ID, I am now delving into the process for deploying apps using ABM and Jamf.  

I have "purchased' (It's actually free app) the app in ABM and it looks like that part went fine.  I first tried just pushing the app we purchased to the iPad first; we received the same error (The MDM request is Invalid".      Next, I decided to try a different approach and have the user download it themselves through the Jamf Self Service App.   However, I'm getting the same MDM error when trying to deploy Self Service app to the iPad.  Basically, I can't seem to get anything pushed to it.   

Valued Contributor II

I assume this is a cloud instance of Jamf Pro and isn't running on an on-premise server? Are you able to make configuration profile changes and then see the resulting change on the iPad?

Also make sure that Assign Content Purchased in Volume  is checked under the Managed Distribution tab of your apps.

Correct; this is a cloud instance of Jamf Pro.  

I was able to create a test configuration profile and make some dock modifications successfully.  That part is working.  

I checked in the Managed Distribution Tab for the Jamf Self Service app, and I see this:



Valued Contributor II

Thanks Sir!  That was the piece I was missing!  As I was reading the documentation, I thought VPP was an optional component to this, as it was worded (as if it was just another way of managing licenses for ABM purchased apps). I see now that it was a requirement for distributing them.  I found, as I was adding a mobile app in Jamf, where I can specific in the search options for volume licenses, and I now see the app listed in there from ABM.   

I tried the 'automatic install' of Jamf Self Service, but that failed again with the same error.  However, following your instructions of Manual install, I was able to successfully set it up and push it out.     

Thanks again for the tip I was missing!