Recon 9.81 Issues


Hi guys,

I was wondering if anyone else has seen the below issues?

  1. Upgrade to 9.81 caused all 10.9 machines to open up the force quit window displaying that apps were being paused. On closer inspection when the agent was running it seems to be opening the "yes" process which is built in Apple stress test, it can open anywhere from 1 - multiple instances of this. The jamf agent also using anywhere from 8GB to 17GB+ memory (really weird as the retina it was on only had 16GB...)

  2. I now have 10.10.5 machines that were working fine that are now not. they are also struggling with Recon I have had to turn the inventory update off to actually stop it from seizing machines up. Although the Yosemite machines do not actually bring up the "apps paused" issue.

Earlier today when this started the java process on the server was at 500% CPU usage, as that obviously would not do I upgraded java to whatever has been latest 1.8 on SDK and update Web 8 update 66 I think it is. This then calmed the server down and I decided to upgrade MYSQL, the latest version of that which is 5.7.9 just simply would not work it produces a password at the end of the install that just does not work to access the database as root. I had to go to the version before which was 5.6.27 which has now got the server up and running again. This server was working perfectly fine on 9.8 and this is the second attempt I have made to upgrade it to 9.81 and it has failed. anyone seen this behaviour? Is there something I have missed?

When I run a verbose jamf enroll it just hangs at the last app that is in the apps folder, if I run a recon through the app it either dies on locating hardware information or at gathering application usage information. (the command does seem to get further , but proceeds no further than the last app in the folder).

The server is running 10.10.5 btw... I have also renewed the push cert as that was also coming up as an error on certain machines I was testing the Recon on.

Looking like new server to me.... Although I am not even sure that would resolve the issue as like I said this box was perfectly fine previous to this update....