Recon hangs on Locating hardware information

New Contributor III

I am seeing recon hang on some machines.

Anybody else seeing this?

It hangs at "Gatekeeper status: App Store and identified developers"



Contributor III

Been seeing this also

Valued Contributor

New Contributor III

Our recon hanging issue was really related to softwareupdate not completing. JamF uses that during recon or inventory management. You can turn that off which support advised us to until this PI is resolved. 


Going into the Inventory Collections Settings in Computer Management, and deselecting "Collect available software updates" also fixed this issue for me.

New Contributor III

Disabling "Collect available software updates" also fixed this issue for me.

Valued Contributor II

This worked for me as well.  Can't say security will appreciate turning that off though.  

New Contributor III

Hello !

I had the same problem: it hangs at the gatekeeper status with the -verbose option, and at the collect hardware informations without it.

I found a command that solved the problem for me:
sudo launchctl kickstart -k system/

The solution was found here:

I just have to wait if it happens again or if it's solved once for all.

Thank you so much, this command from Michael Heap's site fixed my software update being stuck!

Valued Contributor II

I also had 1 specific Mac that would stall during the Recon task at "Locating hardware information (macOS 11.6.6)". When running with the -verbose option it appeared to stall at the very end (after EAs are processed). I examined the EAs and even disabled a couple temporarily but it didn't matter.

Then I ran sudo launchctl kickstart -k system/  (via @Spillou spillou above) and Recon still stalled. I think that I ran Recon too soon after kickstarting softwareupdated. So I waited a couple of minutes and the next time Recon was attempted it ran 100%.

Intel Mac Mini running Big Sur 11.6.6. Jamf Pro 10.37.2.

New Contributor III

Hi !
I had 7 or 8 computers with my inventory update policy that failed. In the mail notification of the failed policy was mention of a time out of 300 seconds for the software update. I tried a jamf recon and it hanged at the same place as written above. Moreover, I couldn't get the mac updates in the preferences pane, of course !

Now I have a policy with the launchctl kickstart command and I run it when needed (just add the computers in the scope) but I would like to know how I can make a policy that applies when the software update hangs. Any help is welcome !

New Contributor III

It's now a few days that I have each morning some computers having this problem. They aren't always the same computers who have the software update that times out after 300 seconds.

I have a policy that triggers at checkin (15 minutes) with the update inventory in the maintenance section configured. I added a files and processes where I put the command that kickstarts the software update. Question is: in the column, the Maintenance configuration is before the Files and Processes one. Does it mean that it will run before the kickstart command ? If so, it shouldn't be a big problem as the maintenance will time out after 5 minutes, the softwareupdate will be forced to restart and then it should be ok at the next checkin 15 minutes later. Am I right ? And I as thinking of replacing this with a single script with the launchctl... followed by a jamf recon. What's the best practice ?

Thank you for your suggestions.


Having a very similar issue to you. Did you have any luck getting yours resolved?


Upgrading away from Big Sur solved this issue for me.

Unfortunately we've seen devices on Ventura throw the same message today when attempting to run an update inventory policy. 

New Contributor III

It happens sometimes on some computers even on Monterey. I tried to remove the maintenance files and processes and replace this with a script that kills the softwareupdate process then makes a recon, but I have now a Connection failure: "The Internet connection appears to be offline." sometimes...

I see a similar issue here on a Intel MacBook running macOS 13.5.1. Recon takes hours and ends with a "Internet connection ..." message, of course ... after 6 or 8 hours the User closes the MacBook...

It looks like that this issue only occurs on Intel Macs, right?