(Resolved) DisplayLink: Allow Screen Recording Not Working?

New Contributor III


I'm currently configuring all things Jamf for my company and am having some trouble with DisplayLink. Currently I have configuration profiles set up to allow standard users to permit screen recording on Teams, Splashtop, and Zoom. So, when users are prompted to allow screen recording, they don't need to be an admin to do this. I tried the same method on DisplayLink, but it remains greyed out. Is there an extra step like allowing a Kernel or PPPC for this to work? See the screenshot and if you need more information, please let me know!

Edit: Resolved. The profile I uploaded was corrupted. New profile with the same configuration was used and it worked fine.


Thanks in advance!DisplayLink Config.PNG


Contributor III

I know this is pretty old, but did you have to do anything else to get it work? 

New Contributor III

I made the profile in a software called pppc utility and set the permissions there. Something got messed up in the creation of the profile (I assume?) and when I went into the configuration profile, removed the "allow standard users to allow access" portion of it, re-added it in Jamf, and then it worked.

New Contributor

Hi @JSKeller,

Where I can find the configuration of the DisplayLink for allowing screen recording automatically?

We want to deploy this in our company and currently for configuration.

Many thanks,

New Contributor II

Thx, it works!!