Self Service App on iOS fails to connect

Not applicable

When I launch the Self Service app on iOS, it fails to connect to the server.

I have to close the app and relaunch.

I’ve been using Jamf (hosted) for 18 months now and no matter what client os version or Self Service app version this is always the case.

iPads are enrolled by me, the app is assigned to groups and installed automatically.

The host name is present in the app config.

Any ideas?


New Contributor II

Hi Adam, I've had this issues as well, and this is what solved problem for me.

Change Self Service for iOS to (Manual Installation) and make sure you've got Smart Groups setup.

Remove Existing Self Service from your iPads.

Navigate to Mobile Devices > Mobile Device Apps > Self Service

Inside App configuration paste this with your JSS URL

<string>$UDID</string> <key>JSS_URL</key> <string>https://JSSURL:8443/</string>

Save, and install Self Service on iPads again and hopefully this will solve your issue. It did for me.

Hopefully this will help

Not applicable

@FilioTech Thank you for your reply.
I do have the app config data entered.

I’m a bit confused how I go about making it as a manual install. Do you mean a user would browse the App Store and download? I’m not using MAID yet.

The app is scoped to (mostly) smart groups but also a few edge cases are static.

New Contributor II

Hi @atomczynskid205

In Settings > Self Service > iOS > choose Neither (Manual Installation). Otherwise, users would get constant popups asking to Login to App Store.

Then use Smart Device Groups and Scope to install to the All Managed iPads (or another group) and Self Service will be installed as soon as iPad is enrolled.

You need to make sure Self Service is deleted from iPads and reinstalled with app config data.

It worked for me.

New Contributor III

We have the same issue. It feels like nothing is working out of the box as it should do. Why can't Jamf make these change to the app instead of every single Jamf user making custom changes?


I have noticed that with all of the updated of our JSS on our iPads I am constantly having to reinstall the Self Service app. Especially on iPads that have been enrolled by the URL and not DEP. Our Self Service is set up to manual and has the code in it. I have had to reinstall the app on almost all of our teacher iPads due to the same error as the OP.