Self Service is empty


Self Service normally works great for me, but one end-user was problematic. Each time that particular student launched Self Service, it was empty. No categories. No policies.

Searching JAMF Nation, I did not find a fix. Thus, I am now sharing my ultimate solution. For the problematic end-user, delete the file:

The client was running Mac OS 10.7.5. CasperSuite is at version 8.63.


Valued Contributor III

So we had a similar issue. It showed a blank screen in self service but only for one user on the computer. After some poking around and knowing that Self Service is browser based (Using Safari) the user in question had turned blocking on for all cookies which caused it to block access to the JSS. Funny enough I also could not log into the jss using this user's safari. After setting cookies to only block 3rd party and ads, everything worked normally again. Weird...

Gabe Shackney
Princeton Public Schools

Gabe Shackney
Princeton Public Schools

Valued Contributor II

Silly question. If you've scoped your policies by department or building check to make sure that he/she is assigned a proper department/building. This may very well not be your issue, but I've seen it before.


I'm having issues with this exact same thing.

Self-service being blank for one user on a machine but not the other.

Things I've tried so far:
- Clear caches.
- Remove the .plist @dmohs][/url suggested.
- Purged the machine (run purge in terminal)
- Chucked the .plists for self-service.
- Deleted the and ran sudo jamf policy to get it to redownload.
- Removed the management framework.
- Re-enrolled the machine.

And the issue persists.

Any ideas?

Will check if cookies are enabled as suggested above.

New Contributor

Hello Makander,
Just curious, are there user policies scoped to this machine? Does the user's account need to be added to a group of any sort?


Valued Contributor II

When Self Service is blank, do you get this across multiple users on the machine?

If so, the fix below is likely.

Since JAMF re-did Self Service in 9.something, when I've had this issue, deleting ~/Library/Caches/com.jamfsoftware.selfservice seems to do the trick for me.

Valued Contributor II

I had a user stop by with an empty Self Service on Mac OS 10.9.5. The JAMF binary on the system was 9.81 and she had block cookies set to Always in Safari. Like @gshackney suggested, I changed the setting to "From third parties and advertisers" and Self Service began functioning normally again. For fun, I decided to try blocking cookies always on my computer with 10.10.5 and my Self Service stopped working as well. In 10.11.2 it didn't matter if I always blocked cookies in Safari, Self Service would work regardless. So if you're having trouble with Self Service being empty and deleting the caches as @RobertHammen suggests then you might want to verify they aren't always blocking cookies in Safari. I have had a couple instances where Self Service got corrupted and it needed to be deleted and reinstalled like @makander mentions above. So these three options have resolved issues with Self Service in most cases.

New Contributor II


That worked for me with a high school student machine just now.



Safari and blocked cookies were the cause of this for me. I unblocked cookies in Safari and it fixed the problem.