Self-Service Web-Clip Bugs

CairoJXP
Contributor

**I've noticed on multiple iPad models on various iOS versions that the self-service doesn't respond well when you interact with it. I'll tap on a button at the bottom and nothing responds. Sometimes it responds immediately, other times you have to touch/hold for 1-2 seconds which may seem petty, but significant in terms of proper interaction.

**Upon installing apps from self service, the items don't disappear until maybe you close and re-open self-service or in some cases, reboot the device completely.

**When installing an update, it appears as if the app updates, but afterwards, the update doesn't disappear from self-service

**Another issue is that when you add the app in JSS and choose "make available in self-service," it shows up in self-service but shows as pending vs. install.

**I also removed an old version of an app from being pushed to a smart device group, deleted the app from the ipads directly, added the latest version of the app in JSS and scoped it to the group and the app then showed up in updates vs. the app store.

Anyone else notice issues like this?

2 REPLIES 2

cdenesha
Valued Contributor II

I'm playing with the web clip now, with one iPad on iOS 8.3 as reference and others at 9.0.1; all new iPad Airs. JSS 9.80

I've noticed on multiple iPad models on various iOS versions that the self-service doesn't respond well when you interact with it.

I'm seeing it on the iOS 8.3 iPad. I thought it was not sending the press/touch, but I do see it briefly change to blue as I press it. I thought perhaps it was my server being too busy to service the request but the iOS 9.0.1 iPad next to it is not having any trouble. I even switched hands in case it was me. πŸ™‚

Upon installing apps from self service, the items don't disappear until maybe you close and re-open self-service or in some cases, reboot the device completely

The items presented by Casper are based on the app inventory of the device. There is a pending command 'Installed App List' that waits a few minutes and then kicks off and collect app inventory to see if the update was successful. Until then the app stays in Self Service, and it'll say 'pending' if you refresh. If you Update Inventory as soon as you know the app has installed you can get an immediate update (a blank push works too). Do you think this is what you're seeing?

When installing an update, it appears as if the app updates, but afterwards, the update doesn't disappear from self-service

I'm talking to my TAM about this now, as it is critical with a disabled Apple App Store.

cdenesha
Valued Contributor II
When installing an update, it appears as if the app updates, but afterwards, the update doesn't disappear from self-service
I'm talking to my TAM about this now, as it is critical with a disabled Apple App Store.

D-009142. When using the Self Service Web Clip, apps appear in the Updates tab whether or not there is an update made available for them.