Shared iPad temporary user storage problems

New Contributor

Today I Setup up pool IPads with temporary guest user only on shared iPads and couldn’t install all apps. There was a lot of available space on the iPads. What did I miss?


Valued Contributor II

I was about to start a new thread on this. I'm seeing wild inconsistencies on Jamf School for this as well. I've set it for one user or I've set it for allocated storage of 2,3,4,5 GB and yet the device itself reports 15gb have been set aside for that one user. JS reports one user with 17GB for that user. Confusing as all get out and what's worse is that after each successive wipe of the device the storage reports differ, not wildly but differ nonetheless. 

I use shared iPads with temporary user for forgetful students or other purposes and up until 14.5 it's been relatively stable and consistent on the management side.


We have the same problem here: on several (new or old) ipad (all with iOS 15.3.1 or 15.4 and 32GB):
It shows an "No Storage Error" while trying to login as guest.
How did you solved the problem?

No matter if we deploy a DEP Profil with a max. number of 4 users or standard or storage quot.
The problem still remains. The storage information shows incorrect free space.
On several iPads we can login as guest, on others login works fine but there seems not be enough space to install any apps. 

What else can we try?


Contributor III

We are seeing the same issues with space and shared iPads that are using temporary session only. The iPads fill up and then give out of space messages and become unusable.. I can send commands to set the number of users to one or the allocation space to the max storage of the iPad, such as 32000 for a 32 GB iPad, but this only seems to free up a little bit of space, and it appears that they will run out of space again in a short period of time. Imaging a iPad is another way to free up some space again but the space is completely in accurate. For instance a 32 GB iPad with only eight apps installed shows in total capacity space of  15 GB with only 2 GB available,  that kind of thing. Although it varies between iPads. I don’t know what to do and I’ve sent an email out to our Apple engineer that works with colleges in our area. 

New Contributor III



Unfortunatly we didnt solved the problem. Only after "hundreds" wiped and resets it worked. Sometimes it seemed to help to wipe an reenroll the device as not-shared but with the default profil. But not always. It was and is very frustrating.




Contributor III

Hello all,

Giving an update to this issue. It is still impacting our shared iPads. We have seen this issue on Shared iPads running Temporary Session Only on iPadOS up to 15.5. I'll be updating them today to 15.7 and seeing if that makes a difference.

I have to send a command 2x a week to reset the iPad storage allocation and that gets them working again for a little bit. It is a big problem.

I am calling Jamf today to make sure I am following Shared iPad best practices and if so, reaching back out to our Apple Engineer who said he would then escalate the case.

If I can't get it working shortly, such as when we upgrade them to iPadOS 16, I will take them off of Shared iPad mode. This would be unfortunate as there is a strong use case for this in our college environments with iPad carts that are used by multiple students, as one example.

Anyone else still dealing with this issue?

Contributor III

Update to this issue:

I have an open ticket with Jamf support and am keeping the Apple engineer we work with in the loop. I've discovered some odd behavior which may have allowed us to resolve the issue, or at least delay the amount of time it takes for iPads using Temporary Session Only to give the storage full error.

So, when one of our Shared iPads that uses Temporary Session Only give us the storage full error and the user can't log in for a guest session, my way of getting the iPads working again is to send a command to the iPads to adjust the storage space. There are two ways that I have done this in the past. One is to set the number of users to "1", the other is to change the storage quota to match the max amount of storage reflected by the iPad's hardware. Both of these approaches get a Shared iPad with the storage full error to start allowing guest logins again. This temporary fix appears to last for up to a week, maybe less.

The new info: I was playing around with the setting the storage quota to different amounts to see how it affected the storage capacity and storage available listed in settings>general>about on the iPads. I have noticed that with the above two commands in the last paragraph the storage on the iPad is altered to be completely inaccurate. For instance, a 64 GB iPad using temporary session only shows the capacity of 26 GB with available space of 2 GB.  I have found that the less I set the storage for in Jamf Pro in the Adjust Shared iPad Settings in Jamf Pro, the more space the iPad has in settings>general>about. To my understanding this is completely opposite what the expected behavior would be.

After trial and error I found that "2049", which is a little over 2 GB, is the lowest storage quota that I can broadcast to our 32, 64 and 128 GB iPads to set the capacity and available to the highest amount possible. In my testing a 64 GB iPad showing 26 GB capacity and 2 GB available changes to 62 GB capacity and 37 GB available when you send the command to set the max storage quota to "2049". An 128 GB iPad went from 24/2 to 126/106. A 32 GB iPad went from 21/2 to 30/12.

I don't know if this will stop the space on these iPads from filling up, but because the command is causing the iPads to show more storage overall to work with, I am hoping if nothing else we will have to send the command to reset the storage space less often. We were sending the reset commands twice weekly before this latest finding.

I hope this helps someone dealing with the issue. I have sent my findings to Jamf support last week but haven't heard back yet.

Contributor III

Update: it turns out that what I thought was a bug was expected behavior. Jamf support said:

"Yes, that is correct if we lower the storage quota for a shared device, that will restrict the storage space consumed by a local user account therefore granting more available space for the iOS device’s system and capacity. "


I understand this to mean that on a Shared iPad, the numbers in "Capacity" and "Available" go UP the lower you set the "Storage Quota" for shared iPads, as it makes the space available for the temporary guest session smaller, making the overall space for apps and system-wide data larger.


Jamf support is looking into why enabling "Temporary Session Only" appears to lower the "Capacity" and "Available"  on the iPad to dangerous levels, which ends up triggering the out of storage errors, preventing sign in.

New Contributor III


Unfortunately we still have the problem with  the storage full error on our "Guest Login" and "Temporary Sessions only" iPads.

Is there something new we should know or we can do?


Hello @smassard, I have found no way to prevent this issue with "Temporary Session Only".  If you send a command to "Allow Managed Apple ID login" and set the storage quota to “2048” (MB) or higher then you should be okay. A storage quota of "2048" sets the space used by the temporary guest session to as small as possible, allowing the greatest amount of space for system files and applications. I suppose if the guest sessions were doing something that used up more storage (like recording a lot of video as a random example), you might want to set that number higher, to give the guest session a little more space to work. "5000" instead of "2048" for instance. 


I am still dialoging with Jamf about how to get “Temporary Session Only” working again without the iPad saying it is out of storage. I think I summarized it already, but apparently what is happening is that when “Temporary Session Only” is enabled, the size of the temporary guest session user account is made as large as possible, thereby leaving the barest amount of space for system files and apps. Any updates to apps start to trigger the out of space warning as there is no space left for them because the “Temporary Session Only” mode is inflating the guest user session to a size that leaves no space left for anything else. That is my current understanding of what is happening. I am following up with Jamf Pro on this today and will post an update when I have one.

New Contributor III


How do you change the storage quota?
Unfortunately changing it under the "devices" tab, doesnt seem to work:

Screenshot 2022-11-10 133532.jpg

Contributor III

@smassard what Jamf product are you attempting to do this in? I do not recognize the UI of the screenshot you posted.

Valued Contributor II

Appears to be Jamf School from a quick glance at it.

New Contributor III

Any news on this topic?


Not really. I opened a second ticket via the feedback assistant app because the first one was closed with a comment that there wasn't enough info. I also have been keeping my local Apple SSE up to date.

Currently all of my shared iPads have temporary session only mode turned off and seem to be okay.

I have some iPads in my office that I am testing, but am having trouble recreating this issue now, so I am not sure how to move forward. 

I would prefer to have all of my Shared iPads in Temporary storage only mode, but taking them out of it was the only thing that seemed to resolve the out of storage issue, so I am reluctant to put them back into that mode.

Are are things with your devices @smassard ? Are you still having the issue? If so, can you provide some details as to how your Shared iPads are configured? For instance, are they in Temporary Session Only mode? What version of iPadOS?

New Contributor III

@dtmille2 I have been experiencing the same issue with a class set of iPads we have (running iOS 15.4)..

I just updated them all to iOS 16.3.1 in the hope it will fix the issue (only to run into PI-110838: iPads in Shared iPad mode lose supervised status after the iPadOS 16.2 update), but not holding out much hope. 

I will log a ticket with Jamf Support also, mentioning this thread and hope it adds weight to a very serious issue with Temporary Sessions on Shared iPads (which would be an awesome feature if it wasn't hampered by this fatal bug).

hi all, I have been following this discussion for 6 months now. I have the same issue but using intune.

Same error, Shared ipad with guest logon. No matter what size iPad 32/64gb, the profile does not leave enough space for the apps etc 

@insurin are you seeing this specifically when the Shared iPads are in Temporary User Only mode?


Settings below. It works brilliantly and will even log the user out after 2 hours of inactivity (students just put them in the cab without signing out). On a 32/64gb iPad, it leaves circa only 1gb of space that gets filled up pretty quickly making it useless.

Require Shared iPad temporary session only - yes

Maximum seconds of inactivity until temporary session logs out - 7200
To get around this I tried a different profile. This one (below) presents the user with an Apple ID and password login box but also has guest mode in the bottom right. I don't get the space issue with this profile but it does not log out the user after 2 hours for some reason.
User Affinity & Authentication Method
User affinity
Enroll without User Affinity
Management Options
Locked enrollment
Shared iPad
Maximum cached users:
Maximum seconds after screen lock before password is required
Maximum seconds of inactivity until user session logs out
Require Shared iPad temporary session only
Not configured
Maximum seconds of inactivity until temporary session logs out
Sync with computers:
Deny All
Device Name
Apply device name template (supervised only)
Apart from Apple fixing this, my only other hope is to use the new federated access now available in Apple School Manager so my students may be able to login using this profile with their Azure credentials to get into the iPad.



New Contributor II

I am seeing this issue as well with a 64GB 10th gen iPad running 16.5. Does anyone have any updates or workarounds?

Valued Contributor II

Just in case anyone missed this. The enterprise changes for iPadOS 17 list this as an enhancement versus a bug fix. So this appears to have not been supported up until now with 17.x.

  • Temporary session: A Shared iPad configured for temporary sessions now honors the QuotaSize key for the temporary user. This key helps reserve sufficient space to install apps or other media while a user is signed in.

Same error, iPad running on 17.1.1, the MDM flag may be honoured by the device but I cannot set it for Temporary Sessions.

New Contributor

You had my hopes up then. on my 9th Gen 64GB models with Require Shared iPad temporary session only. I get the following

capacity = 64GB

Available = 2GB

Guests Storage capacity = 50.14GB

Guests Available Storage = 50.04GB

As soon as I install an app, it reduces the available storage from 2GB. This means they will run out of storage pretty quickly. This is the issue I have had all along so the issue still persists for me.

Contributor II

Still an issue on 17.1.1, I've raised an FR:

Contributor III

Temporary Session Only mode still broken on 17.3

2GB of storage available for the system with no way to allot more.

iPads quickly become unusable (impossible to log in as a temporary user), unless you allow Apple ID login, and adjust the allocated storage for the user (make it less).