Shared iPads gets private adress enabled on upgrade to ipadOS 14

mooler
New Contributor III

Tried the upgrade on some shared iPads to see how compatible it would be right out of the box and found that all devices lost internet connection.

After some digging I found the "private adress" was enabled by default in the wifisettings and that was the culprit of the error. Our routers does not seem to be handling this setting well.

Did a search in JAMF to find out if it is possible to disable this to avoid manual work on upgrading our 1000+ units to 14 further ahead. I could not find any payloads for this setting.

We're on JAMF 10.21 and I'm checking to see if there might be some more input on the subject?

4 REPLIES 4

informatiqueSFS
New Contributor

Hello,
Same issue here. The update has been set by a colleague and I can't find any way to cancel it.
It's troublesome as all our devices are bound to an IP through their MAC, to assign them firewall profiles. Our ip subnet went full as all the upgraded ipads asked new IPs. I've started to downgrade a few by hand but can't and won't for the ~30 in this case.

Please let us setup this option in the profiles !

Olson
New Contributor II

Yes, I have iOS 14 on a 30-day locked out for the majority of our Middle School iPads. A few teachers updated their iPads and got bit by this. We lock our iPads network settings after getting fed up with students turning the WiFi off. So when they do update, they won't be able to flip the switch for Private Address, I'm hoping something can be done in Profiles too.

fsjjeff
Contributor II

Struggling with this as well. There is a new setting in the Wifi config profile to "Disable MAC Address Randomization (iOS 14 or later)", but it was only released with JAMF 10.24.1, which came out the same day as iOS 14, which made it pretty hard to plan for much in advance :(.

mooler
New Contributor III

Yes, we're gonna upgrade to 10.24 and check if that new payload setting might do the trick. Til then it's manual work...