Single-Sign on Extension will not automatically connect

dhausman
New Contributor III

Hi, hoping someone will be able to help with my single-sign on extension. I have NoMAD and NoMAD LoginAD setup. It works great, but I was testing the single-sign on extension to see how it worked. I though it was great, I have it set up and for the most part it work. I am having trouble keeping it connected. Like NoMAD it will only work when I am connected via VPN so it can talk to my AD servers. When I connect to VPN, NoMAD would connect up. My single-sign on extension stays greyed out after I connect to VPN unless I tell it to reconnect. I have automatic login enabled on the profile and set to allow. I have sync turned on to sync my local password. What am I missing here? Advice? I am pretty sure I am just missing a setting somewhere.

7 REPLIES 7

Harrie
New Contributor III

Hi, in our case it works fine with VPN
Maybe you can share your .plist so we can check

dhausman
New Contributor III

Good point. Here is my plist

Dan

putnajoe
New Contributor III

I have noticed that the SSO extension in Big Sur behaves normally in 11.0.1 but exhibits the same behavior under 11.1 where it does not connect automatically anymore.

dhausman
New Contributor III

Thanks I am on 11.1 so that helps.

putnajoe
New Contributor III

I tried the 11.2 beta at the suggestion of my Apple SE and the SSO extension is working as expected once again for me.

dhausman
New Contributor III

Is this how you have it set up? Mine is not reconnecting automatically and I am on 11.2.1

f45c57e6046647b19ce597c9f230257f

dhausman
New Contributor III

Just to follow up, I think my configuration profile was corrupt. I copied it to a new one and deleted the old one, and everything worked as expected.