Smart Group showing similar names in polices

jacbgla
New Contributor II

Hi,

Need a little help with some smart groups; I have Labs setup within Smart Groups - "Lab-C119-Mac" This brings back 20 machines - like it should

When I want to build a policy around this smart group - it always seems to gather machines from other Labs containing similar names, For Example: "Lab-Mac-M329-10"

I have even contained Lab C119 into its own building and again, the smart group looks correct, However I still have the same issue in Policies.

Screenshots attached

84e1cb2670524c42877aee26a8486cf9
7cb9f980c50d4a1db4e5c485651df5d7

Thanks, Jeremy

1 ACCEPTED SOLUTION

Aziz
Valued Contributor

You'll need to change "Target All Users" to "Target Specific Users". That should show the correct scope.

View solution in original post

17 REPLIES 17

mpermann
Valued Contributor II

@jacbgla can you show a screen shot of the Smart Group logic and the Policy Scoping including any limitations or exclusions in the scoping. That might help narrow down where the problem is.

jacbgla
New Contributor II

Hi

Logic (All Machines have the correct building info)

2335f06fa66549cea07c761795ff1f7e

Scope - No Limitations or exclusions are set.

90a50279b090434aa7b6b802f371cf73

Jeremy (ps.. i hated the smart group section at the cct course)

mpermann
Valued Contributor II

@jacbgla the logic and scoping looks fine to me. That's really weird. Is it possible that the six computers containing Lab-M in their name could have been assigned Lab-C119 names and there is some corruption in their database records that would account for them showing in that smart group? Generally, for the handful of lab computers we have, we usually assign them to static groups and scope them that way. But your smart groups should work. Maybe your TAM has would have some idea about what could be causing the issue.

mm2270
Legendary Contributor II

@jacbgla I might be wrong or just confused on this, but looking at your screenshots, I see the following:

Target Computers Computers to deploy the policy to [ Specific Computers ] Target Users Users to deploy the policy to [ All Users ]

If you only wanted to deploy this to target computers in the Smart Group I don't think the Target Users section should be showing up in the Scope section of the policy. I think its the fact that the Target Users is there at all and set to "All Users" that you are getting things off with the actual scope.
But since I'm not yet on JSS 9.82, may I ask what version you're running? Is this perhaps something new that shows up with 9.8x that I'm just not aware of? I can't even make a policy show both of those items like you have in your screenshot, so I'm unclear how it got set up that way.
Also, what are the triggers set for this policy by the way? Is it Login / Logout or Self Service? Or something like Recurring Check-in?

mpermann
Valued Contributor II

@jacbgla I think @mm2270 is onto something. I didn't pay close enough attention to that. When I am targeting a specific smart group I have specific computers and specific users in the drop downs. Maybe if you change the users drop down to specific users that will resolve your issue.

Aziz
Valued Contributor

You'll need to change "Target All Users" to "Target Specific Users". That should show the correct scope.

View solution in original post

jacbgla
New Contributor II

Hi All

Thanks for all your responses. It looks like @Abdiaziz is correct, I am sure I have tried this before, nevertheless it seems to be working correctly now. Thankyou!

e694b1566dd1491d9feff1093e5a1350
e60e69ef7c5a4f9d82e6fb908cbcb976

I will keep an eye on it and see what happens.

(P.S We are running JSS 9.8)

Jeremy

mm2270
Legendary Contributor II

I have to ask the question, because my curiosity is really getting to me on this, but HOW exactly are you able to get both "Target Computers" and "Target Users" drop downs to show up under the Scope section of your policy? Is this related to having imported users from your JSS inventory into the "Users" tab in the JSS? Because if so, that would explain why I don't see that anywhere on our JSS. We haven't done that here.
I even tried looking at this on our 9.82 dev JSS, thinking this was something new in the 9.8x versions that I missed, but I wasn't able to make it appear there either, so it doesn't seem like its specific to a recent release.

bpavlov
Honored Contributor

I believe this was introduced with one of the 9.8 releases. I think you need have to LDAP. I would check the release notes for either 9.80 or 9.81 (we're on 9.81 and previously on 9.73 which did not have that).

mpermann
Valued Contributor II

I have a test box running 9.82 that has no LDAP configured or any users setup under the Users tab and I see the Target Users drop down.

mm2270
Legendary Contributor II

Interesting. Looking at the full Administration guide for 9.82, I see this on page 257, under the Managing Policies section:

7. Click the Scope tab and configure the scope of the policy. If you have migrated users, you can add users and computers as targets to the scope. If you have not migrated users yet, you can only add computers as targets to the scope.

emphasis is mine.
That seems to indicate migrating users into the Users section is required for this to work. But, @mpermann, you're saying you have no Users imported on your JSS, but you see the option anyway? Are you certain? Did you attempt a users import perhaps at one point?

mpermann
Valued Contributor II

@mm2270 on my test JSS 9.82 I did have a single user in the system that I added manually from the "User and Location" tab on a computer record in the test JSS. But I had removed the user not long after I setup the system as I was going to mess around with getting LDAP setup but just haven't done it yet. Maybe just the act of having had a user at one point is what allowed that box to appear. I've been playing around with installing the JSS in an Ubuntu EC2 t2.micro AWS instance lately just for fun. So I may spin up a new instance to see if I can narrow down if that is the reason or not.

mm2270
Legendary Contributor II

@mpermann Yeah, I have a feeling doing the import, even if you end up removing the users imported, or if it doesn't import any users, would allow that drop down to appear. At least that's my guess as to what's going on. If so, it all makes sense. We have not done any import. I still see a large "button" panel with the text "Migrate Users" on it when I click on the Users tab. This would explain why we don't see it.

Thanks for confirming from your end. Its all good information, and it gives me some inclination to do the import so we can perhaps make use of that scoping feature.

bpavlov
Honored Contributor

FWIW, I don't recall ever having to "migrate" users but we do have all our LDAP users showing up.

mm2270
Legendary Contributor II

@bpavlov Thanks for checking on that. I guess however they managed to get in there, consider my curiosity on this satisfied 🙂 As it does seem this is the key/missing piece to getting that option to show up there.

mpermann
Valued Contributor II

@mm2270 and @bpavlov I think mm2270 has been using JSS since before version 9. There was a Migrate Users button that had to be pressed to get enhanced user functionality for those upgrading from the older JSS version. That button isn't there is you start a fresh instance. When I setup 9.82 from scratch I didn't see that button and didn't "import" any users. I just added the one user manually as I stated above.

bpavlov
Honored Contributor

Gotcha. I've only been here a little over a year and we were on v9 at that point. But I believe this JSS has gone through previous upgrades going back as far as v8. So it may or may not have been done at some point here. Interesting to know either way how that feature works/shows up.