SMB Volumes Not Displaying on Finder Desktop


In my environment I've noticed that SOME SMB volumes (2012R2 Servers) don't display on the Desktop as expected. What's curious is that two shares on the same server will behave differently. One will display and another won't.

I've had difficultly in getting my Windows server admin to troubleshoot this issue. Is there a known setting on the server that would cause this to happen?



Valued Contributor II

There is no Windows server setting I can imagine that would cause this issue. Your Windows server admins are right to avoid this one.

If you mount a device using unix tools (/sbin/mount) then I suspect it will not show up on the desktop, but if you mount it via the Mac OS (Go Menu -> Connect to server), then it should show up, if configured to do so.

I've been wrong plenty of times before, but I can't imagine any situation where one server would show on the desktop and not another when mounted the same way....

Honored Contributor

I was thinking maybe the name of the share may have something funky with it. Does it start with a period like ".Sharename"? or possibly a forward slash / or colon : ? Is the name similar to the shares that do mount?

One server side setting to check would be to get Properties on the foler being shared out and make sure the "Hidden" box is not checked. I've seen that cause mounting problems.


I'm not trying to mount the volumes via mount_afp or mount_smbfs on the command line. This is occurring using your typical "Connect to server" via Command-K.

What's curious is that we don't see this issue when connecting to the volumes via AFP (ExtremeZ-IP or whatever it's now called). We only discovered it when looking at moving users from AFP to SMB.

The volume names are not funky, WIP and WIP_2_DM


New Contributor III

I am seeing the same behavior when I launch Casper Admin. Previously, it would mount "Caspershare" on the desktop. So, if you wanted to, you could manually copy files from the share. Now, when I launch Casper Admin (version 9.98) it mounts the Caspershare in /Volumes but not on the desktop. Our server is a RHEL 7.1 machine and we now mount using SMB. Still haven't found the issue but it seems to be related to using SMB.

Valued Contributor III

@AARP I believe this is deliberate change of behaviour for Casper Admin and JAMF have changed the option when it is mounted to nobrowse.
The OP's post is a different issue thoughas Command-K should mount to desktop.