SMTP server and Office 365

kdbillings74
New Contributor

I am trying to setup out JSS to relay messages out to Office 365. All of our mailboxes are in the cloud.I have it setup to use smtp.office365.com on port 587 with SSL. Anyone else set this up and have any info. I keep getting an error when sending a test email.

14 REPLIES 14

daz_wallace
Contributor III
Contributor III

Hi @kdbillings74

We have this running with our JSS at the moment.

The only difference we have is using TLS instead of SSL

I'd suggest giving that a go. Good luck!

Darren

typeraj
New Contributor III

Hi @kdbillings74

Did you ever get this working? We have the same issue. Tried @daz_wallace 's suggestion but that didn't work.

thanks
Raj

typeraj
New Contributor III

We figured it out - you need to use TLS and the UPN in the username field for it to work.

vobizzy
New Contributor III

Well played, it worked for me. Thanks @typeraj

swahedi
New Contributor

How do you setup smtp setting for Office 365 with no on prem smtp server?

cthomp
New Contributor

not working for me tried all encryption settings combined with UPN

markdmatthews
Contributor

try the following (although this will be an issue when MSFT deprecates BasicAuth)
Server and Port: smtp.outlok.com : 587
Encryption: TLSv1.2
Requires Authentication: Enable + Add UID/PASS

KyleEricson
Valued Contributor

Yeah any news from Jamf to support the new modern auth with SMTP?


Hire me as an independent contractor.

CollegeAhuntsic
New Contributor

we are in october 2021. still cannot use the smtp with our azure modern auth. smtp basicauth is disable on azure.

anyone has found a solution ? 

sabel9579
New Contributor

Same boat.  Can't get SMTP to work with O365

jsmith_pbs
New Contributor

pray
New Contributor

I have the same problem, and have a consultant assisting us with our setup who does not know why it's not working.

Set this up with an account that is NOT enabled for MFA, with the SMTP authentication enabled.

Using port 587 with TLSv1.2 (tried the others also).

UPN for the username

Tried the workaround posted by jsmith_pbs.

Still not working. 

ERROR:Error sending message.
SUGGESTION:Ensure you can connect to the SMTP Server.

 

markdmatthews
Contributor

Just to re-confirm what I am using (successfully):

Server: smtp.outlook.com
Port: 587
Connection Timeout: 5s
Requires Authentication: <username> <password>
Encryption: TLSv1.2

Thanks for the feedback!

I tried that, still failing.

  • Tried both smtp.office365.com and smtp.outlook.com
  • both ports 25 and 587
  • Connection timeout from 5 to 20 seconds
  • With and without authentication
  • All encryption options

And every combination possible of the above

Verified the password on the account, verified that it is NOT enabled for MFA, verified that the account is enabled and can log in, and that SMTP authentication is enabled on the account.

I also created a connector in Exchange online, with all the IP addresses Jamf lists as sending IPs

Also verified that there are no conditional access policies that would be blocking.

 

Still no joy.

Might be a lost cause, but I've opened a support case with Jamf about this.

 

We've been working with a consultant to help us get up to speed on Jamf for Mac management, and he can't figure it out either.