Target Mode Imaging 10.13 Already APFS

markc0
New Contributor III

Hello, prior to 10.13 i was using Casper TMI to image our macs.
Whilst dep is all well and good what about when you want to erase the disk to re-deploy the machine elsewhere?
Well i was on the understanding if the mac is already 10.13 and the ssd was converted to APFS then you could re-image.
Whilst this took an hour to install the OS (OS is 10.13.1 APFS AutoDMG)without error, upon startup the mac does not boot.
Any ideas?

5 REPLIES 5

richmac
New Contributor III

Target disk mode imaging is no longer supported and neither is imaging in the traditional way. You would need to use the recovery partition to restore the OS or alternatively do an internet recovery.

Here is some info on APFS from JAMF.
APFS Whitepaper

mike_paul
Contributor III

For clarification, Target Disk mode imaging and imaging in general is still supported for 10.13, APFS formatted or not. What changed is Imaging to upgrade is no longer supported, re-imaging existing hardware already upgraded is supported, with caveats (mostly around forked builds and firmware installations). Recovery Partition and Internet recovery are valid options to re-install as well but imaging is still a thing.

Whats called out in that white paper linked above which refrences this Apple KB Upgrade macOS on a Mac at your institution is that "Installing macOS High Sierra on a Mac that is connected by Target Disk Mode isn't a supported installation method" in regards to upgrading to 10.13 and is in the upgrading section of that KB. This is due to the fact that the macOS installer you get from the App Store needs to be able to have a network connection to be able to verify its contents and a target computer booted to TMI does not have a network connection. Running the macOS installer is the only approved method to get to 10.13.

Now if you have a computer that has already been upgraded to 10.13 and got the firmware and other goodies during the upgrade installation, you can use the standard imaging methods to re-image; e.g. NetBoot, external drive and Target Mode. Per that same kb "Monolithic system imaging can only be used to re-install macOS, not to upgrade to a new macOS version."

In regards to the problems that @markc0 is seeing if its taking an hour to lay down an image, especially over target mode, then something else is happening that would cause it not to do a block copy. Sometimes thats due to Erase not being checked, sometimes permissions on a share and could be other things. I just used Jamf Imaging for a Target Mode restore of an autoDMG image to a target computer that was already on 10.13 and formatted for APFS and it laid down the image in about a minute and booted fine.

The fact that its not booting could be a few things as well but one of the reasons why both Apple and Jamf are encouraging people to look to knew options other than imaging is we will be seeing more forked builds with new hardware such as the touch bar Macs that would need a different build than typical computers so you will have to maintain more images depending on your fleet.

You could take Jamf Imaging out of the picture to just confirm that your image will work on your target computer by using just the standard ASR command line options (which is basically what imaging is doing anyway).

Look
Valued Contributor III

I'm using NetInstall to install 10.13.1 seems to work without any issues. It appears to go away to the internet and download the required firmware update as you get a failure to that effect if the internet is not available.
You can add extra packages to it as well, but a few of the features are currently broken so your limited to a single files only pkg and can't use scripts or pkgs that automatically run scripts or auto selecting a drive name for imaging.

markc0
New Contributor III

Thanks Mike for your info, this is what i thought when you explained this to me at the recent Jamf roadshow in London.
I have installed the macOS via recovery disk and this worked but is slow like 30mins, therefore i would prefer to carry on TMI just for re-Imaging.
However i still having issues with the APFS image, the HFs works fine.
I have re-made this image using AutoDMG and still the same, I have also ensured that Erase drives is selected.
I have posted some screen grabs showing this.
af6048293063404fb1fb18178af9c615
2c73d754be3a4c7fb7501c4c884120cd I tried an asr command to restore the image, sudo asr --source /Casper Replica/Packages/osx_updated_171103-10.13.1-17B48apfs.dmg --target /Volumes/Macintosh HD 3 --erase
i got the error Validating target...done Validating source...done Erase contents of /dev/disk2s1 (/Volumes/Macintosh HD 3)? [ny]: y Repartitioning target device...
Could not repartition target device
Therefore with Casper Imaging 9.101.0 could i be correct in saying it cant wipe the disk which is why the image is being so slow to lay down?
df was showing /Volumes/Macintosh HD 3 as /dev/disk2s1
so i tried sudo asr --source /Casper Replica/Packages/osx_updated_171103-10.13.1-17B48apfs.dmg --target /dev/disk2s1 --erase
this failed as above, but then looking at diskutil /dev/disk1 (external): #: TYPE NAME SIZE IDENTIFIER 0: GUID_partition_scheme 512.1 GB disk1 1: EFI EFI 209.7 MB disk1s1 2: Apple_APFS Container disk2 511.9 GB disk1s2
/dev/disk2 (synthesized): #: TYPE NAME SIZE IDENTIFIER 0: APFS Container Scheme - +511.9 GB disk2 Physical Store disk1s2 1: APFS Volume Macintosh HD 29.5 GB disk2s1 2: APFS Volume Preboot 18.9 MB disk2s2 3: APFS Volume Recovery 520.7 MB disk2s3 4: APFS Volume VM 2.1 GB disk2s4
I could see Macintosh HD was on /dev/disk1s2 not /dev/disk2s1
so when i changed sudo asr --source /Casper Replica/Packages/osx_updated_171103-10.13.1-17B48apfs.dmg --target /dev/disk1s2 --erase this worked fine and i can boot into the os fine.

Not sure now where i go from here
Thanks

mm2270
Legendary Contributor II

Yes, the issue is it's not erasing the drive. That is apparent in the fact that in the Jamf/Casper Imaging screenshot it's displaying "Installing Package..." instead of "Block Copying..." If it's installing it, then it couldn't erase the volume. It would always block copy if the drive was reformatted.

I don't have any more to offer you on this as I don't use Jamf Imaging these days. But I also see you're using version 9.101.0, which, I think would be compatible with APFS and High Sierra systems, so I don't have an explanation.