TeamViewer 13, anyone deploying it? Am I missing something?

PatrickD
Contributor II

Hi All!

TLDR at the bottom.

I have been working to create a POC for TeamViewer 13 in our org for macOS and Windows.

Wondering if anyone has had experience with deploying TV 13 or other versions?

We need to deploy the software to all of our computers "silently" (the first launch dialogue box is fine) and have them register in the TeamViewer Management console. This is so we can just select the computer and offer remote assistance without needing to ask the customer for an "ID".

First thing to do is "configure" the host installer by adding branding, selecting to use the assignment tool (to assign the client to the management console), applying the relevant policy and group etc. You then are provided with a download link to the pkg installer.

The installer is "customised" by including the Configuration ID (for your custom settings) in the file name eg Install TeamViewerHost-idcxyzxyzx.pkg which I then assume, during installation, the installer goes out to TeamViewer and fetches the relevant settings, branding images etc.

The installer itself has an issue, which I have raised with TeamViewer, where if there is a space in the file path, the post install script is unable to the identify the configuration ID. eg. getting Jamf Pro to install the pkg as per standard practice fails because it is installed from /Library/Application Support/JAMF/Downloads/ (I think the sub dir is Downloads?). "Application Support" has a space and therefore it fails, I found this after reading through the install logs way too many times.

Anyways, I have found a way around that by caching the pkg and using a script to move it to the /tmp/ dir and installing it from there. This works but then I have to wait for TeamViewer to launch so that the Assignment.json file is created in /Library/... so that I can then run the TeamVierwer Assignment executable with the Configuration ID and API token just to get the client to register in the management console.

Surely it isn't meant to be this hard, AV products are a single pkg install with built in assignment to a management console. Am I missing something here?

Any help would be greatly appreciated!

Cheers,
Pat

TLDR: Why is TeamViewer so difficult to mass deploy?

9 REPLIES 9

Santosh_BR
New Contributor III

We have deployed Team Viewer in mass by creating a package using Composer, never had any issues...!! Give a try using composer, it should ideally work πŸ™‚

pete_c
Contributor II

I had saved this how-to from v12, but never had a chance to put it into production in that environment - hope it's of some use:

http://hcsonline.com/images/How_to_Auto_Configure_TeamViewer_for_Mass_Deployment.pdf

DA001KL
New Contributor III

Who are you working with from TV ? I have also deployed this to our mac's and it took some tweaking. In composer add a postinstall script in the install to handle the install script that TV recommends

PatrickD
Contributor II

Thanks @pete_c, that is essentially the process we are using however that is all bundled into a pkg.

@DA001KL, I have just been working with TV support. I asked them about other methods that some of their customers may use but I just go the token line of "This is the only method".

I am pretty disappointed with TV, I expected a lot more from their software.

jamesandre
Contributor

Thanks for the "a space in the file path" info. Couldn't work out why it was behaving differently when deployed via Jamf.

vaksai
New Contributor II

I went with the composer path, works as intended.
If only there was a way to grab teamviewer ID to the JSS though...

KevinWorden
New Contributor II

@vaksai Below is how I get the TV ID via ssh connection, i just wrote it into an Extension Attribute. I'm new to Jamf this is my first one, so please test. I don't have TV 13 yet, so I have not tested with it. But works TV 10-12.

Terminal command, SSH or ARD way:

/usr/libexec/PlistBuddy -c Print:ClientID /Library/Preferences/com.teamviewer.teamviewer.preferences.plist

Jamf Custom Extension Attribute:

#!/bin/bash
# Returns the TV ID

TVID=$("/usr/libexec/PlistBuddy" -c "Print:ClientID" /Library/Preferences/com.teamviewer.teamviewer.preferences.plist)

echo "<result>${TVID}</result>"

vaksai
New Contributor II

@KevinWorden doesn't seem to work with TV 13, the plist isn't generated and I can't find the ClientID anywhere else.

KevinWorden
New Contributor II

@vaksai I just installed TV13 on a test machine in the office. After your post, I wanted to know if i needed to find a new way to get the ID after I upgrade in a few months. After installing TV13 and going through the unattended setup. It did create the same /Library/Preferences/com.teamviewer.teamviewer.preferences.plist file as it has since at least version 10.

Are you looking in the User or System Library/Prefs folder? you should be looking in the system.