Terminal Error

New Contributor II

When I open my terminal instead of seeing my Mac name (e.g. bp-Macbook)

I'm seeing this on both of my Macs, a restart of the Terminal resolved this on my iMac, but not my Macbook Pro
Has anyone seen this before?

Is this a hack? I ran a Virus scan and Malewarebytes nothing was found, and I don't see another account in the terminal


Valued Contributor II

It looks like your default prompt has changed? Did you install any tools that modifies your zsh environment? (oh-my-zsh is common)

Open the ~/.zshrc with an editor and look an see if you have anything in there like PROMPT=

Valued Contributor

Is that number your computers serial number or network hardware (MAC) address?

New Contributor II

Thanks for the response, this happened on two Macs, no tools were installed. The numbers were the AT&T router.
On an iMac quitting and re-opening the terminal a couple of times fixed it. On the other, a MacBook, a restart fixed it. Everything looks ok in the file. I've had no issues since then. Thanks again