This Apple Package did not have a valid file. Assuming it is a flat file package.

Not applicable

Any ideas why this might be happening guys ???

The installer requires a restart after installation, but it shouldn't prevent the package from being created.


Andrew Jezard
(MacBook Program Administrator)

Sacred Heart College
Retreat Road
Newtown, VIC, 3220

Tel: (03) 5222 0520
Fax: (03) 5221 3634


Esteemed Contributor II

Hi Andrew,

I believe Casper Admin is supposed to embed a *.bom (bill of
materials) into the package when you upload the it to JSS? I had a
similar problem with an AAMEE generated Adobe CS5 Master Collection
package. JSS showed the same error. Once I re-uploaded the package,
the requisite *.bom file was created and the problem went away.



Esteemed Contributor II

Still seeing these errors in 9.61:

This package is a PKG or an MPKG, and the file is not found. Attempting to open the package as a flat package...

Policy completes, but curious about the error.



Legendary Contributor II

We see that too, and have for years now, but I don't really think its an "error" per se. Its just a statement that the jamf binary sees that it doesn't contain a .bom and then assumes its a flat package. I guess it would be nice if it didn't actually report that in the log since there isn't any real reason to know that, but I've never seen that message report in the policy reporting that it errored instead of completed successfully.
Are you seeing that message in conjunction with an error being reported back?


We have the same error messages for a long time and just with some packages. I am wondering it just comes up sometimes, although it's the same client downloading the file. Usually after re-uploading this issue is solved, but as mentioned before it's really annoying.

Anyone a different workaround than re-uploading?

Contributor III

Error also occurs on 9.63, using an afp distribution point (http). What is annoying is that this message may occur on a policy that actually fails or a policy that says it fails, but actually works, so I am not sure how much credence to put in the message.

Esteemed Contributor II

@SeanA just grasping at the package flat (did it migrate properly; if new should be flat)?


New Contributor

I saw this once before...I placed the .pkg into a .zip and then uploaded it into the JSS via Casper Admin, the error never happened again....don't know if that necessarily is a fix, but it stopped the error from happening on my end.