~ Tilde appearing in file path rather than users name?

a_holley
Contributor

Hi all,

We use the custom search path option to collect inventory information about applications installed in the local user accounts on our iMacs.
In the past, it used to display as /$username/Desktop/Spotify.app for example. Now, it's coming up at ~/Desktop/Spotify.app

We use hot desks, so the computers can have many many users, and this makes it impossible to find out where these rogue apps are being stored.

I have searched around but can't work out what has caused the change or how I can get it to display the username again.

Has anyone else noticed this and can it be fixed?

Thanks

1 ACCEPTED SOLUTION

craig_hopkins
New Contributor II

If you goto Settings > Computer Management > Inventory collection > Software > Applications you can uncheck Enable Unix User Paths which I think will put it back to how it was (once the computer updates inventory that is)

View solution in original post

3 REPLIES 3

bramstedtb
New Contributor III

Jamf switched to using the tilde instead of the full path in 10.9. From the release notes: "Jamf Pro now uses Unix user paths by default to save space in the application details database table." I don't think there's a way to change it.

a_holley
Contributor

@bramstedtb thanks, good to know. Super frustrating though!

craig_hopkins
New Contributor II

If you goto Settings > Computer Management > Inventory collection > Software > Applications you can uncheck Enable Unix User Paths which I think will put it back to how it was (once the computer updates inventory that is)

View solution in original post