Touch ID macOS Ventura  Wireless KB

Wakko
Contributor

Mi Gente!!!

I don't know where to post this as it's not a JAMF Product issue. However I wanted to share this with the community. Ever since I've I've upgraded to macOS Ventura. My  Wireless Touch ID KB does not work at all. Touch D won't work at log-in or with 1Password as well. I thought his was strange so I N&P™ [starosinstall] and got the same results.

Now if I connect the  KB to my mac(hine) [USB], guess what. It works as advertised! It defeats the entire purpose of the  KB being wireless. Especially since I run my mac(hine) closed to get desk space back.

If I go back to macOS Monty [12.6 or 12.6.1] the Touch ID functionally works as advertised. On log-in screen and with 1Password.

So I have to ask, as anyone else run into this as well? If so hit me up.

+ Gracias 

4 REPLIES 4

sdagley
Honored Contributor III

@Wakko Try deleting the keyboard from your Bluetooth devices list. Be sure to have the USB cable disconnected when you do that, then re-connect the cable to re-pair.

@sdagley I tried that that already same results. I even as far as using a USB-C to lighting cable and got the same results after repairing. Dos different KB as well. However when I repair 'em to a mac(hine) running 12.6 or 12.6.1, it works fine. No issues what so ever. I almost didn't catch it, since I only saw this issue with 1Password. However then I started testing everything else and log-ins and I saw it wouldn't work either. Strange indeed, I'll testing macOS 13.1 later this week and see if it behaves the same or better.

Fveja
New Contributor III

Might be a good idea to send feedback through Feedback Assistant to Apple.  You can do a spotlight search for it.  I'm not familiar with this keyboard, but it may be a bug in the OS.

Wakko
Contributor

@Fveja already on it. I just brought up here incase anyone else runs into this. Hopefully it's just an oversight and is addressed sooner. I'm just trying to save keystrokes so my fingers/hands can continue on my grind with Destiny 2 is all.