Trying to install El Capitan from scratch from USB

New Contributor

I just had the weirdest thing happen. I made a bootable USB drive with the El Capitan installationfor my 2013 13" MacBook Air. When I boot the USB to the El Capitan installation, everything goes through, but for some reason I end up with Yosemite instead of El Capitan... Bizarre! Somehow during the install of El Capitan it decides to switch and install Yosemite instead of El Capitan. Can anyone tell me what's going on here?

Here are more specifics:

I boot the USB stick I made from an El Capitan package that I downloaded from the App Store.

I created the USB stick using this command:

sudo /Applications/Install OS X El --volume /Volumes/Untitled --applicationpath /Applications/Install OS X El –-nointeraction

I boot the USB stick using the Option key and go to Disk Utility and format the internal SSD in the MacBook, which I then verify that it is empty in the end.

I select to install Mac OS X El Capitan to the internal SSD. Again, I am verifying it is in fact installing to the internal SSD, and the screen says "El Capitan" on the screen through the install process.

After 15 mins or so, the MacBook reboots and then automatically starts installing MacOS X again, all automatically, just a progress bar and the Mac OS X logo on the screen. However, this time the screen does not say El Capitan as it did before. It just has a the Mac OS X logo (the big X logo inside the circle). Then it takes about another 15 to 20 mins, and then reboots one more time.

When it starts up again, the first screens load with the Terms and Conditions and says Mac OS X Yosemite. Whatever happened to El Capitan I started installing just minutes ago?

After I create my account and load the desktop, I confirm that it is indeed running Yosemite even though I had started the El Capitan installation.

I repeated this process 3 times today just to verify I wasn't going crazy or missing something, and it went exactly as I described. The last time I did it, I had downloaded a new Mac OS X El Capitan installation package from Apple and once again formatted and recreated the USB stick, and still the same bizarre thing happened.

So now that Yosemite is up and running, I then open that same USB drive in Mac OS and start El Capitan installation once again while Yosemite is running, and then it upgrades Yosemite to El Capitan successfully with no problem. However, using the same package, I cannot install El Capitan by booting the USB from scratch.

I have Googled this and it seems I am the only one with this bizarre thing happening. Does anyone have any clue why I can't install El Capitan from scratch? I can only get El Capitan by upgrading Yosemite.

The reason I need this is because I am testing software for my company and it takes twice as long to upgrade to El Capitan rather than installing El Capitan from scratch.



Hi @verasme from experience what i've used to make bootable OS X disks is a tool called DiskMaker X, It uses the "Install OS X El Capitain" from your /Applications folder which you've downloaded from the App Store, and takes about 10-15 minutes to create a bootable disk without the hassle.

New Contributor

Can you delete this version and redownload it from the MacApp store? Sounds like the Yosemite installer has been renamed.

Does the Startup Disk pref pane show the USB as 10.10 or 10.11?

Contributor III

But seriously, would it kill Apple (and for that matter any/all installer app makers) to have a version file somewhere and to display during the install on a corner of the screen exactly what version/build is being installed?

I'm sorry I don't have anything intelligent to offer in response to this oddness. You're erasing the whole drive not just the previous OS volume (i.e. from the Partitions tab select a new partition scheme) - because all I can think is you're somehow getting redirected to a Yosemite recovery partition. Make sure you don't have an active internet recovery session on your network!

New Contributor

Hi @verasme I've had this exact same issue happen to me multiple times. I was able to resolve this problem by making a few changes to my OS upgrade process. Below you can find the steps that I take when I upgrade OS X using a USB drive. Let me know if you have any issues.

  1. Disconnect yourself from the LAN by unplugging any Ethernet cables.
  2. Turn on your Mac and hold down "Command + R" keys until the Apple logo comes up.
  3. Enter Disk Utility. Now delete your primary partition and format it using OS X Extended Journaled with the Partition name of choice. This is where your OS is going to be installed.
  4. Plug-In your USB drive. Reboot your Mac and keep the "Option" key held down. You should now see your USB drive appear. Follow the wizard to complete the rest of the upgrade.

Note: If you start the process by holding down "Option" you will be redirected to the Yosemite recovery install instead.

New Contributor

Hi. Thanks for all the responses. Since this is a MacBook Air, I have no network connection, no ethernet port, no WiFi connection during the process when it boots from the USB.

What is surprising about this, is that during the El Capitan installation, the agreement screen and the setup screen, they all say OS X El Capitan, and I did this multiple times to confirm I wasn't making a mistake. How can this be the Yosemite recover partition or some "renamed" Yosemite install if everything I am looking at clearly says "El Capitan" 10.11 during the install? The only thing I am suspecting is that "El Capitan" package contains a copy of Yosemite built-in as some form of fall-back mechanism for certain devices that are incompatible with El Capitan, and for some odd reason, maybe a bug in the installation, this El Capitan package is reverting to Yosemite. That's only my speculation from knowing how Apple can sometimes pull "secret weapons" out of nowhere. LOL

@Valenzuela , Typically I would boot from the USB by holding the Option key, and then I open Disk Utility from there. I then format the internal SSD and then quit the Disk Utility which brings me back to the main menu. At that time, I select to install Mac OS X without rebooting. Next time, I will try rebooting after formatting.

By the way, if you've used the Disk Utility that comes with El Capitan installation, you'll notice the interface is quite different than the one that comes with Yosemite. So not only do I see the installation says "El Capitan" during the install, it also comes with a newer version of the Disk Utility.

New Contributor

@verasme, Try first booting using control + R and delete the partition. Reboot and hold down option to install El Capitan. What you just mentioned was exactly how I encountered it and it puzzled me because I've always used the previous method of holding down option and never had any issues during upgrades.

After some time researching this I found an article from Apple with the new documented steps and that's what I've been using since then. FYI - I just tried to upgrade a Yosemite Mac Mini to El Capitan with no internet connection using just "Option" and the steps you followed and it brought me back to Yosemite after the upgrade "Completed". The Disk Utility interface was also the El Capitan GUI just like you described.

I will try to look for that article and update this posting...

New Contributor

Thank you @Valenzuela. If you can find that article that will be great.

New Contributor

You have 2 lines (you and everyone else) that I do not know how to format. I must be the dumbest guy on the planet because no one else posts how either. --applicationpath --volume. It is so frustrating I wish examples would be just that, examples, exactly what typed when you hit enter. Not --volume with no instructions on how to format that info. It may seem like a given to the geeks and gurus but to us little guys just trying to scratch out an answer at home on a Saturday night it is maddening.

Valued Contributor II

@Frustr-As-Hell see if this helps. I have an 8 GB USB flash drive named ElCapitanInstaller that I will be turning into the installer. The drive is formatted with a GUID Partition Map as an OS X Extended and Journaled file system and plugged into the computer I'm using to make the installer USB. In the Applications folder on that computer I have the Install OS X El Capitan application downloaded from the Mac App Store. Now that I have all those conditions met, if I run the command below it should create the installer on the USB drive labeled ElCapitanInstaller.

sudo /Applications/Install OS X El --volume /Volumes/ElCapitanInstaller --applicationpath /Applications/Install OS X El –-nointeraction

To further break down the command. The

/Applications/Install OS X El

is the path to the binary used to created the USB installation drive. The --volume is the switch with the parameter of


which is the path to the USB drive the createinstallmedia binary uses. The --applicationpath switch is using the

/Applications/Install OS X El

parameter which is the path to the OS X El Capitan installer that was downloaded from the Mac App Store. The --nointeraction switch is simply telling the createinstallmedia binary to not require any interaction in the terminal when running the command. Does this explanation help and allow you to make the USB installer media?

New Contributor

That is very clear, sorry for being such novice. Thank You